aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/py-jabberbot
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/py-jabberbot
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/py-jabberbot')
-rw-r--r--unmaintained/py-jabberbot/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/unmaintained/py-jabberbot/APKBUILD b/unmaintained/py-jabberbot/APKBUILD
new file mode 100644
index 0000000000..e0cb560d70
--- /dev/null
+++ b/unmaintained/py-jabberbot/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=py-jabberbot
+_pkgname=python-jabberbot
+pkgver=0.15
+pkgrel=0
+pkgdesc="A simple Jabber Bot for Python"
+url="http://pypi.python.org/pypi/jabberbot"
+arch="noarch"
+license="GPL3+"
+depends="py-xmpppy python"
+makedepends="python-dev"
+install=""
+subpackages=""
+source="http://thpinfo.com/2007/$_pkgname/jabberbot-$pkgver.tar.gz"
+
+_builddir=$srcdir/jabberbot-$pkgver
+build() {
+ cd "$_builddir"
+ python setup.py build
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --root="$pkgdir"
+}
+
+md5sums="081be2f6d8c82740b9906bf5b8562e7d jabberbot-0.15.tar.gz"
+sha256sums="b8b946958e15f5413adcb02fecf7cffd6d008669a692ef6a2bc4bf3717c06a1d jabberbot-0.15.tar.gz"
+sha512sums="57cf8cbd79fd530565308b644b7e22d985e7ce5319eb8d5b127546ded4bf49d3c196a7780321aaf093cb948d1217e4ef7c265b7a3b0f411e5c1999feb591b749 jabberbot-0.15.tar.gz"