aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/py-ostinato
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-28 00:59:57 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-28 00:59:57 +0000
commitac6b452f19bdf2802a708926740891322e5b457d (patch)
treee632428a06cecbe552037e96ff7c8ecbf8e305de /unmaintained/py-ostinato
parent68c4c1600672b5ef21600366456b528bf9467ba5 (diff)
downloadaports-ac6b452f19bdf2802a708926740891322e5b457d.tar.bz2
aports-ac6b452f19bdf2802a708926740891322e5b457d.tar.xz
testing/py-ostinato: move to unmaintained (fails to build)
Diffstat (limited to 'unmaintained/py-ostinato')
-rw-r--r--unmaintained/py-ostinato/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/unmaintained/py-ostinato/APKBUILD b/unmaintained/py-ostinato/APKBUILD
new file mode 100644
index 0000000000..a22e6779af
--- /dev/null
+++ b/unmaintained/py-ostinato/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Corentin Henry <corentinhenry@gmail.com>
+# Maintainer: Corentin Henry <corentinhenry@gmail.com>
+pkgname=py-ostinato
+_pkgname=python-ostinato
+pkgver=0.7.1
+pkgrel=0
+pkgdesc="A Python agent for the ostinato controller"
+url="http://ostinato.org/"
+arch="noarch"
+license="GPLv3"
+depends="python py-protobuf>=2.3.0"
+makedepends="python-dev py-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="903d65182eeb09d1363c81375664c265 python-ostinato-0.7.1.tar.gz"
+sha256sums="f628f3be4c3392676ff703bac33ba6f51bcb951eed52ab9171dbeb4751c59bc0 python-ostinato-0.7.1.tar.gz"
+sha512sums="c80ba3783b551c3869529bb7b3636dd4370d9ff6dd8ea9c39484ea73982af940751a0a332641abb2bff9aa2860064337ec49a95dd507dc6afebb0544b1ae363e python-ostinato-0.7.1.tar.gz"