aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/py-pyacoustid
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-08-26 14:03:26 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-08-26 14:03:26 +0200
commit0f88cd87d9d1b7bb66f429838d41c9ff042f9fe7 (patch)
tree98da9deb6dfd192610025cf8954aa8422b30d605 /unmaintained/py-pyacoustid
parent300140759c1caaec7ea22565facd42b6b79ada90 (diff)
downloadaports-0f88cd87d9d1b7bb66f429838d41c9ff042f9fe7.tar.bz2
aports-0f88cd87d9d1b7bb66f429838d41c9ff042f9fe7.tar.xz
testing/{chromaprint,py-pyacoustid}: move to unmaintained
* chromaprint have not been updated for at least 6 months * py-pyacoustid depends on chromaprint and doesn't have a maintainer
Diffstat (limited to 'unmaintained/py-pyacoustid')
-rw-r--r--unmaintained/py-pyacoustid/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/unmaintained/py-pyacoustid/APKBUILD b/unmaintained/py-pyacoustid/APKBUILD
new file mode 100644
index 0000000000..ead08bd9e7
--- /dev/null
+++ b/unmaintained/py-pyacoustid/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=py-pyacoustid
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="Bindings for Chromaprint acoustic fingerprinting and the Acoustid API"
+url="https://github.com/sampsyo/pyacoustid"
+arch="noarch"
+license="MIT"
+depends="python chromaprint py-requests py-audioread"
+depends_dev=""
+makedepends="python-dev py-setuptools"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/p/pyacoustid/pyacoustid-$pkgver.tar.gz"
+
+_builddir="$srcdir"/pyacoustid-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1 || return 1
+}
+
+md5sums="b27c714d530300b917eb869726334226 pyacoustid-1.1.0.tar.gz"
+sha256sums="0117039cb116af245e6866e8e8bf3c9c8b2853ad087142bd0c2dfc0acc09d452 pyacoustid-1.1.0.tar.gz"
+sha512sums="16b1c6cc1c27c02847b43c953e0fa9d525652b0583e321aaceb2f0c4bbea2e2f6956a6f0a95b1cd61124dc17e0751819ab223513ec22f27cf83246199ea8999d pyacoustid-1.1.0.tar.gz"