aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/py-tftpy
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/py-tftpy
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/py-tftpy')
-rw-r--r--unmaintained/py-tftpy/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/unmaintained/py-tftpy/APKBUILD b/unmaintained/py-tftpy/APKBUILD
new file mode 100644
index 0000000000..e5f7f0577c
--- /dev/null
+++ b/unmaintained/py-tftpy/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=tftpy
+pkgver=0.6.0
+pkgrel=0
+pkgdesc="A Pure Python TFTP Protocol Implementation"
+url="http://tftpy.sourceforge.net/"
+arch="noarch"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="python-dev"
+install=""
+subpackages=""
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="b306d30ef1799f1932540a54cd72f79d tftpy-0.6.0.tar.gz"
+sha256sums="d8de06a543989b910e46d2793f96fb9c5cbd7f99ab014982945b58ae60289893 tftpy-0.6.0.tar.gz"
+sha512sums="f1d3fa00dbb084d077ef727d5fb7d8510bc80537577f5dec8debb1b6b6563443ba0a180d4dd3371fe966e60f9fbfb1aa9eed3559af12642abf0c8b89efb82ee3 tftpy-0.6.0.tar.gz"