aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/py-xattr
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/py-xattr
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/py-xattr')
-rw-r--r--unmaintained/py-xattr/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/unmaintained/py-xattr/APKBUILD b/unmaintained/py-xattr/APKBUILD
new file mode 100644
index 0000000000..ece10bf523
--- /dev/null
+++ b/unmaintained/py-xattr/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-xattr
+_pkgname=pyxattr
+pkgver=0.5.2
+pkgrel=1
+pkgdesc="A python module for accessing filesystem Extended Attributes"
+url="http://pyxattr.k1024.org/"
+arch="all"
+license="LGPL2+"
+depends=""
+depends_dev=""
+makedepends="python-dev attr-dev py-setuptools"
+install=""
+subpackages=""
+source="http://pyxattr.k1024.org/downloads/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python setup.py install --root="$pkgdir" || return 1
+}
+
+md5sums="9ff2e4218badc201b689b6d254290001 pyxattr-0.5.2.tar.gz"
+sha256sums="19accb3927a833b36b1fb0fddeae45c32b08715cce38b1b106faff22c4ba79d9 pyxattr-0.5.2.tar.gz"
+sha512sums="8dfe6583b1bb54c1674ca90ea99ad50d7ad51b858a1f40bfd4a3660fcba71b59540e5957bb601d816e82c9fec91985394f51193e5a2452c4b1b27cb5edf51e2f pyxattr-0.5.2.tar.gz"