aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/rinse
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/rinse
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/rinse')
-rw-r--r--unmaintained/rinse/APKBUILD51
-rw-r--r--unmaintained/rinse/rinse-device-nodes.patch19
-rw-r--r--unmaintained/rinse/rinse-posix-cpio-use.patch11
-rw-r--r--unmaintained/rinse/rinse-set-rpm-platform.patch100
4 files changed, 181 insertions, 0 deletions
diff --git a/unmaintained/rinse/APKBUILD b/unmaintained/rinse/APKBUILD
new file mode 100644
index 0000000000..e8936e4d04
--- /dev/null
+++ b/unmaintained/rinse/APKBUILD
@@ -0,0 +1,51 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=rinse
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="A RPM chroot bootstrapping tool"
+url="http://www.steve.org.uk/Software/rinse/"
+arch="noarch"
+license="Artistic"
+depends="rpm perl wget perl-libwww"
+depends_dev=""
+makedepends="$depends_dev gzip coreutils"
+install=""
+subpackages="$pkgname-doc"
+source="http://www.steve.org.uk/Software/rinse/rinse-$pkgver.tar.gz
+ rinse-posix-cpio-use.patch
+ rinse-device-nodes.patch
+ rinse-set-rpm-platform.patch"
+
+_builddir="$srcdir"/rinse-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+}
+
+package() {
+ cd "$_builddir"
+ make PREFIX="$pkgdir" install || return 1
+}
+
+md5sums="1221942846f4caa6e621cfc85f759841 rinse-2.0.1.tar.gz
+6761f834b3f50bded544021ccb90c700 rinse-posix-cpio-use.patch
+6a6092323c1973832f5c050d37265d99 rinse-device-nodes.patch
+e292f3192df193924f86ef1f20bee745 rinse-set-rpm-platform.patch"
+sha256sums="74b1149cb6f12c1bd51e371e5decf4820489535afa9b93900780817cbae7f96b rinse-2.0.1.tar.gz
+f869904261add72b2e6a50f910fc79fae44b68df617c8d0d1e1e02d99c77e165 rinse-posix-cpio-use.patch
+dfb972611d74889902d1f25edf6bd172aaa8ef62c352a5e966c2892c568171e8 rinse-device-nodes.patch
+e6d789e0fc67658eac0b1c11ae32e5407aaf2eb09fa479b5e42f94a28526f8df rinse-set-rpm-platform.patch"
+sha512sums="4d6284dfd5bdaac1c2578222203c5dd1bfcd325b756583238c45a064da2345ed75615461464845d721026d3ee1b2bab55f138c9fd5d911f7b41a4e7af5ab9cd8 rinse-2.0.1.tar.gz
+a8ff20b382fa05bf921d1a99fcf7f1e147a63ff7b2c1d04c312ac9d1148d8acb07c56a016176f081a6c2c6797d31a5bd3607b1d891517888931c42bde9a58465 rinse-posix-cpio-use.patch
+9bca1bbbe11453d80f06d330af5695a874240a274ea671f30fd3383f2a88e5e0c73a167aa4ac10f3fde6f9df0cda5678ef436de3ed111a16b008128aafb2a196 rinse-device-nodes.patch
+4e50dafbdd39d1f057a459173e0eac355c0ed592e9d7741a479610915b65ae2e2872ede776fbaca332a8aec20ef94c70ca3b77639670827647634fe276d8731a rinse-set-rpm-platform.patch"
diff --git a/unmaintained/rinse/rinse-device-nodes.patch b/unmaintained/rinse/rinse-device-nodes.patch
new file mode 100644
index 0000000000..a4300f1818
--- /dev/null
+++ b/unmaintained/rinse/rinse-device-nodes.patch
@@ -0,0 +1,19 @@
+--- rinse-2.0.orig/scripts.common/20-dev-zero.sh
++++ rinse-2.0/scripts.common/20-dev-zero.sh
+@@ -34,4 +34,16 @@
+ if [ ! -e "${prefix}/dev/zero" ]; then
+ mknod -m 666 "${prefix}/dev/zero" c 1 5
+ fi
++if [ ! -e "${prefix}/dev/urandom" ]; then
++ mknod -m 666 "${prefix}/dev/urandom" c 1 9
++fi
++if [ ! -e "${prefix}/dev/random" ]; then
++ mknod -m 666 "${prefix}/dev/random" c 1 8
++fi
++if [ ! -e "${prefix}/dev/null" ]; then
++ mknod -m 666 "${prefix}/dev/null" c 1 3
++fi
++if [ ! -e "${prefix}/dev/console" ]; then
++ mknod -m 666 "${prefix}/dev/console" c 5 1
++fi
+
diff --git a/unmaintained/rinse/rinse-posix-cpio-use.patch b/unmaintained/rinse/rinse-posix-cpio-use.patch
new file mode 100644
index 0000000000..429410f981
--- /dev/null
+++ b/unmaintained/rinse/rinse-posix-cpio-use.patch
@@ -0,0 +1,11 @@
+--- rinse-2.0.orig/bin/rinse
++++ rinse-2.0/bin/rinse
+@@ -1144,7 +1144,7 @@
+ # Run the unpacking command.
+ #
+ my $cmd =
+- "rpm2cpio $file | (cd $CONFIG{'directory'} ; cpio --extract --make-directories --no-absolute-filenames --preserve-modification-time) 2>/dev/null >/dev/null";
++ "rpm2cpio $file | (cd $CONFIG{'directory'} ; cpio -idm) 2>/dev/null >/dev/null";
+ if ( $file =~ /(fedora|centos|redhat|mandriva)-release-/ )
+ {
+ my $rpmname = basename($file);
diff --git a/unmaintained/rinse/rinse-set-rpm-platform.patch b/unmaintained/rinse/rinse-set-rpm-platform.patch
new file mode 100644
index 0000000000..a5eae642b8
--- /dev/null
+++ b/unmaintained/rinse/rinse-set-rpm-platform.patch
@@ -0,0 +1,100 @@
+--- rinse-2.0.1.orig/scripts/centos-5/post-install.sh
++++ rinse-2.0.1/scripts/centos-5/post-install.sh
+@@ -10,6 +10,17 @@
+ exit
+ fi
+
++# specify platform
++echo " post-install.sh : arch is ${ARCH}"
++if [ "${ARCH}" = "amd64" -o "${ARCH}" = "x86_64" ]; then
++ arch=x86_64
++ echo $arch-redhat-linux > ${prefix}/etc/rpm/platform
++fi
++if [ "${ARCH}" = "i386" ]; then
++ arch=i686
++ echo $arch-redhat-linux > ${prefix}/etc/rpm/platform
++fi
++
+ # rpm's can now be removed
+ rm -f ${prefix}/*.rpm
+
+--- rinse-2.0.1.orig/scripts/centos-6/post-install.sh
++++ rinse-2.0.1/scripts/centos-6/post-install.sh
+@@ -10,6 +10,17 @@
+ exit
+ fi
+
++# specify platform
++echo " post-install.sh : arch is ${ARCH}"
++if [ "${ARCH}" = "amd64" -o "${ARCH}" = "x86_64" ]; then
++ arch=x86_64
++ echo $arch-redhat-linux > ${prefix}/etc/rpm/platform
++fi
++if [ "${ARCH}" = "i386" ]; then
++ arch=i686
++ echo $arch-redhat-linux > ${prefix}/etc/rpm/platform
++fi
++
+ # rpm's can now be removed
+ rm -f ${prefix}/*.rpm
+
+--- rinse-2.0.1.orig/scripts/rhel-5/post-install.sh
++++ rinse-2.0.1/scripts/rhel-5/post-install.sh
+@@ -10,6 +10,17 @@
+ exit
+ fi
+
++# specify platform
++echo " post-install.sh : arch is ${ARCH}"
++if [ "${ARCH}" = "amd64" -o "${ARCH}" = "x86_64" ] ; then
++ arch=x86_64
++ echo $arch-redhat-linux > ${prefix}/etc/rpm/platform
++fi
++if [ "${ARCH}" = "i386" ]; then
++ arch=i686
++ echo $arch-redhat-linux > ${prefix}/etc/rpm/platform
++fi
++
+ # rpm's can now be removed
+ rm -f ${prefix}/*.rpm
+
+--- rinse-2.0.1.orig/scripts/slc-5/post-install.sh
++++ rinse-2.0.1/scripts/slc-5/post-install.sh
+@@ -10,6 +10,17 @@
+ exit
+ fi
+
++# specify platform
++echo " post-install.sh : arch is ${ARCH}"
++if [ "${ARCH}" = "amd64" -o "${ARCH}" = "x86_64" ] ; then
++ arch=x86_64
++ echo $arch-redhat-linux > ${prefix}/etc/rpm/platform
++fi
++if [ "${ARCH}" = "i386" ]; then
++ arch=i686
++ echo $arch-redhat-linux > ${prefix}/etc/rpm/platform
++fi
++
+ # rpm's can now be removed
+ rm -f ${prefix}/*.rpm
+
+--- rinse-2.0.1.orig/scripts/slc-6/post-install.sh
++++ rinse-2.0.1/scripts/slc-6/post-install.sh
+@@ -10,6 +10,17 @@
+ exit
+ fi
+
++# specify platform
++echo " post-install.sh : arch is ${ARCH}"
++if [ "${ARCH}" = "amd64" -o "${ARCH}" = "x86_64" ] ; then
++ arch=x86_64
++ echo $arch-redhat-linux > ${prefix}/etc/rpm/platform
++fi
++if [ "${ARCH}" = "i386" ]; then
++ arch=i686
++ echo $arch-redhat-linux > ${prefix}/etc/rpm/platform
++fi
++
+ # rpm's can now be removed
+ rm -f ${prefix}/*.rpm
+