aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/rpmlint
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/rpmlint
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/rpmlint')
-rw-r--r--unmaintained/rpmlint/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/unmaintained/rpmlint/APKBUILD b/unmaintained/rpmlint/APKBUILD
new file mode 100644
index 0000000000..9bbbad58b0
--- /dev/null
+++ b/unmaintained/rpmlint/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=rpmlint
+pkgver=1.6
+pkgrel=0
+pkgdesc="A tool for checking common errors in RPM packages"
+url="http://rpmlint.zarb.org"
+arch="noarch"
+license="GPL2"
+depends="python"
+depends_dev=""
+makedepends="python-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.xz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="ad09ff960c7f3561af59f7886f3619ef rpmlint-1.6.tar.xz"
+sha256sums="a0dae71a3fed413ee5c47bd04f393cd6598c68c0dcf1504fa020d62814ff674b rpmlint-1.6.tar.xz"
+sha512sums="1eb8281af40accbc8b0273b552dcb6ccbc8973cbd8a86128205a05e7e98fd0598f0dd7e74e3844e28580111f1d37a11c15014fbd20202464591f5721ed3eca52 rpmlint-1.6.tar.xz"