aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/ruby-hoe/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-04-29 08:11:47 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-04-29 12:36:41 +0000
commit80acbaee801184140fac0c967cbb8aa051db2b06 (patch)
tree77c8128eadea951dd93cce5ba6632c5ddc120426 /unmaintained/ruby-hoe/APKBUILD
parent5db5ee5c13e577e862e822501b2e4863fbd63195 (diff)
downloadaports-80acbaee801184140fac0c967cbb8aa051db2b06.tar.bz2
aports-80acbaee801184140fac0c967cbb8aa051db2b06.tar.xz
move testing/ruby-* to unmaintained
ruby-mime-types and ruby-nokogiri was there already so remove those
Diffstat (limited to 'unmaintained/ruby-hoe/APKBUILD')
-rw-r--r--unmaintained/ruby-hoe/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/unmaintained/ruby-hoe/APKBUILD b/unmaintained/ruby-hoe/APKBUILD
new file mode 100644
index 0000000000..22c5b45630
--- /dev/null
+++ b/unmaintained/ruby-hoe/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+
+_gemname=hoe
+pkgname=ruby-$_gemname
+pkgver=3.13.1
+pkgrel=0
+pkgdesc="Hoe is a rake/rubygems helper for project Rakefiles"
+arch="noarch"
+url="http://www.zenspider.com/projects/hoe.html"
+license="MIT"
+depends="ruby"
+depends_dev=
+makedepends="$depends_dev"
+source="https://rubygems.org/downloads/$_gemname-$pkgver.gem"
+_builddir="$srcdir"/$_gemname-$pkgver
+build() {
+ mkdir -p "$_builddir" || return 1
+ export _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')"
+ gem install $_gemname -v $pkgver -i "$_builddir"$_gemdir \
+ --ignore-dependencies \
+ --verbose \
+ --no-rdoc \
+ --no-ri \
+ || return 1
+ rm -rf "$pkgdir"/$_gemdir/cache \
+ "$pkgdir"/$_geminstdir/ext \
+ "$pkgdir"/$_geminstdir/.require_paths
+}
+
+package() {
+ mkdir -p "$pkgdir" || return 1
+ cp -ra "$_builddir"/* "$pkgdir"/ || return 1
+}
+
+md5sums="739d4ede50ba5bf9fabb03cef59c3737 hoe-3.13.1.gem"
+sha256sums="18414316a39bc828b4b943aed6817774ce23642fa6b51450b25ae596e7084cd5 hoe-3.13.1.gem"
+sha512sums="9962f7cdf3179e5073c63983e5ee20926399c17769d1588292427d1bb7f765d3444fbefa57edaa610dc053a5bd3bd0ba16bf627ca0713e88e4b7f039435b127e hoe-3.13.1.gem"