aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/scantailor
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/scantailor
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/scantailor')
-rw-r--r--unmaintained/scantailor/APKBUILD53
1 files changed, 53 insertions, 0 deletions
diff --git a/unmaintained/scantailor/APKBUILD b/unmaintained/scantailor/APKBUILD
new file mode 100644
index 0000000000..c6e8689dd4
--- /dev/null
+++ b/unmaintained/scantailor/APKBUILD
@@ -0,0 +1,53 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=scantailor
+pkgver=0.9.11.1
+pkgrel=0
+pkgdesc="Interactive post-processing tool for scanned pages"
+url="http://scantailor.sourceforge.net"
+arch="all"
+license="GPL"
+depends=""
+depends_dev="qt-dev boost-dev libjpeg-turbo-dev tiff-dev"
+makedepends="$depends_dev cmake"
+install=""
+subpackages="$pkgname-cli"
+source="http://downloads.sourceforge.net/scantailor/scantailor-$pkgver.tar.gz"
+
+_builddir="$srcdir"/scantailor-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ cmake \
+ -DCMAKE_CXX_FLAGS="-DBOOST_NO_MEMBER_TEMPLATE_FRIENDS" \
+ -DCMAKE_CXX_FLAGS_DEBUG="-DBOOST_NO_MEMBER_TEMPLATE_FRIENDS" \
+ -DCMAKE_CXX_FLAGS_RELEASE="-DBOOST_NO_MEMBER_TEMPLATE_FRIENDS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release .
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+cli() {
+ pkgdesc="scantailer cli"
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir/"usr/bin/scantailor-cli \
+ "$subpkgdir"/usr/bin/
+}
+
+md5sums="6cdca1b6d1dafd022ea94b4800dad340 scantailor-0.9.11.1.tar.gz"
+sha256sums="881647a4172c55a067a7b6687965441cf21176d79d93075b22a373ea9accd8d3 scantailor-0.9.11.1.tar.gz"
+sha512sums="cec327fd12144f7cee5043adfee3880c75fb147474e4c3b5166385f7a8f47cb5650ed2df930bbe1f4b8ac2c7229a887ecba1ca105b47b1023f5d3d7d7b54bdb4 scantailor-0.9.11.1.tar.gz"