aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/scrub
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/scrub
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/scrub')
-rw-r--r--unmaintained/scrub/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/unmaintained/scrub/APKBUILD b/unmaintained/scrub/APKBUILD
new file mode 100644
index 0000000000..4e2dc3a2c5
--- /dev/null
+++ b/unmaintained/scrub/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=scrub
+pkgver=2.6.1
+pkgrel=0
+pkgdesc="A disk overwrite utility"
+url="http://code.google.com/p/diskscrub/"
+arch="all"
+license="GPL2+"
+depends=""
+depends_dev=""
+makedepends="perl"
+install=""
+subpackages="$pkgname-doc"
+source="https://github.com/chaos/scrub/releases/download/$pkgver/scrub-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="46801354b01f0c619207d6f2df796a6b scrub-2.6.1.tar.gz"
+sha256sums="43d98d3795bc2de7920efe81ef2c5de4e9ed1f903c35c939a7d65adc416d6cb8 scrub-2.6.1.tar.gz"
+sha512sums="6e434b9d81c5ac473188c37af790c808771204203b3f04a5ca316c6a890f872d1beb73ce4713546e14ae91287d7adaf2fbfa44a30af634c2b3af890e2a0e8640 scrub-2.6.1.tar.gz"