aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/shared-desktop-ontologies
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/shared-desktop-ontologies
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/shared-desktop-ontologies')
-rw-r--r--unmaintained/shared-desktop-ontologies/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/unmaintained/shared-desktop-ontologies/APKBUILD b/unmaintained/shared-desktop-ontologies/APKBUILD
new file mode 100644
index 0000000000..f92bf231d5
--- /dev/null
+++ b/unmaintained/shared-desktop-ontologies/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer:
+pkgname=shared-desktop-ontologies
+pkgver=0.6.0
+pkgrel=0
+pkgdesc="shared desktop ontologies library"
+url="http://oscaf.sourceforge.net/"
+arch="noarch"
+license="BSD"
+depends=
+depends_dev="cmake"
+makedepends="$depends_dev"
+install=""
+subpackages=
+source="http://downloads.sourceforge.net/project/oscaf/shared-desktop-ontologies/0.6/shared-desktop-ontologies-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/shared-desktop-ontologies-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ mkdir "$_builddir"/build
+}
+
+build() {
+ cd "$_builddir"/build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_SKIP_RPATH=ON "$_builddir" || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"/build
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="2651122ac27de95e91973ed6b88ccf94 shared-desktop-ontologies-0.6.0.tar.bz2"