aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/sipcrack
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/sipcrack
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/sipcrack')
-rw-r--r--unmaintained/sipcrack/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/unmaintained/sipcrack/APKBUILD b/unmaintained/sipcrack/APKBUILD
new file mode 100644
index 0000000000..293772c644
--- /dev/null
+++ b/unmaintained/sipcrack/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=sipcrack
+pkgver=0.2
+pkgrel=0
+pkgdesc="A SIP protocol login cracker"
+url="http://packages.debian.org/lenny/sipcrack"
+arch="all"
+license="Custom"
+depends=""
+depends_dev=""
+makedepends="libpcap-dev openssl-dev"
+install=""
+subpackages=""
+source="http://ftp.de.debian.org/debian/pool/main/s/$pkgname/"$pkgname"_"$pkgver".orig.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ for file in sipcrack sipdump; do
+ install -Dm 0755 $file "$pkgdir"/usr/bin/$file || return 1
+ done
+}
+
+md5sums="b9096c8d537fc231c7d74b759831a4c7 sipcrack_0.2.orig.tar.gz"
+sha256sums="5f356dbce7d09c009005af1a49c55e05ae66c8db4e44de862c5191898c49ae6e sipcrack_0.2.orig.tar.gz"
+sha512sums="406c0f0ac4f23529e2d58f131c571492fd655d27bb466a5b972cef2c7b8ca5d550d6055ad405a4180b711a5f29027a8d47b43a912b4859ef9fccdb85069a1c45 sipcrack_0.2.orig.tar.gz"