aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/sofia-sip
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/sofia-sip
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/sofia-sip')
-rw-r--r--unmaintained/sofia-sip/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/unmaintained/sofia-sip/APKBUILD b/unmaintained/sofia-sip/APKBUILD
new file mode 100644
index 0000000000..a441892665
--- /dev/null
+++ b/unmaintained/sofia-sip/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=sofia-sip
+pkgver=1.12.11
+pkgrel=1
+pkgdesc="An open-source SIP User-Agent library"
+url="http://sofia-sip.sourceforge.net"
+arch="all"
+license="LGPL2+"
+depends=""
+depends_dev="libtool openssl-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://downloads.sourceforge.net/sofia-sip/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --prefix=/usr \
+ --enable-64 \
+ --enable-static=yes \
+ --with-openssl \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="f3582c62080eeecd3fa4cd5d4ccb4225 sofia-sip-1.12.11.tar.gz"
+sha256sums="2b01bc2e1826e00d1f7f57d29a2854b15fd5fe24695e47a14a735d195dd37c81 sofia-sip-1.12.11.tar.gz"
+sha512sums="48bef0223ecf5a31267773c8e2491c1990b4419be67154e350cc9e5644a98e55409d635d7828824de3e0e1658caebe5b61e44d613615beb709ecbe8180be131c sofia-sip-1.12.11.tar.gz"