aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/soprano
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/soprano
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/soprano')
-rw-r--r--unmaintained/soprano/APKBUILD47
-rw-r--r--unmaintained/soprano/redland.patch11
-rwxr-xr-xunmaintained/soprano/soprano-2.9.4-dbus-1.patch12
3 files changed, 70 insertions, 0 deletions
diff --git a/unmaintained/soprano/APKBUILD b/unmaintained/soprano/APKBUILD
new file mode 100644
index 0000000000..a918267270
--- /dev/null
+++ b/unmaintained/soprano/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer:
+pkgname=soprano
+pkgver=2.9.4
+pkgrel=5
+pkgdesc="KDE RDF framework"
+url="http://soprano.sourceforge.net/"
+arch="all"
+license="LGPL"
+depends=
+depends_dev="qt-dev raptor2-dev rasqal-dev redland-dev libiodbc-dev clucene-dev"
+makedepends="$depends_dev cmake automoc4 doxygen"
+install=""
+subpackages="$pkgname-dev"
+source="http://sourceforge.net/projects/soprano/files/Soprano/$pkgver/soprano-$pkgver.tar.bz2
+ soprano-2.9.4-dbus-1.patch"
+
+_builddir="$srcdir"/soprano-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ mkdir "$_builddir"/build
+}
+
+build() {
+ cd "$_builddir"/build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr "$_builddir" \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"/build
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="91413e5783efeee0beb747ea4c5c9ef0 soprano-2.9.4.tar.bz2
+46741dc5c70c79c12bde5040bd570e82 soprano-2.9.4-dbus-1.patch"
+sha256sums="64066fbd54e71d7ae4c8a4116997448a72808a2813cff3bb5d2c28f0fce9e0e5 soprano-2.9.4.tar.bz2
+9bd7e2bfed9b99c230c8cea0c56c03b07f076c6722c564e7973116a8ff582d75 soprano-2.9.4-dbus-1.patch"
+sha512sums="3a907d7fa564cc5641e6d620a46efb3c01f8a141fb3a1afdf72422727d968baf00268c2dce420db24de2e86d3373fdd3473eeabaa736170f76bb2672c8ad80b0 soprano-2.9.4.tar.bz2
+9d8fa3bd0763020a401561a87439d10cdaf7f8b61a475e21d6ab4908a0a10d886ec490bbcd4d71ac7420d09ec1637060ba23aa2e27ee0d92ddbd4905694a6493 soprano-2.9.4-dbus-1.patch"
diff --git a/unmaintained/soprano/redland.patch b/unmaintained/soprano/redland.patch
new file mode 100644
index 0000000000..24806db411
--- /dev/null
+++ b/unmaintained/soprano/redland.patch
@@ -0,0 +1,11 @@
+--- soprano-2.6.0.orig/cmake/modules/FindRedland.cmake
++++ soprano-2.6.0/cmake/modules/FindRedland.cmake
+@@ -113,7 +113,7 @@
+ ARGS ${_REDLAND_STORAGE_LIBS}
+ )
+ if(NOT "${_TEST_EXITCODE}" EQUAL 0)
+- set(_REDLAND_VERSION_OK)
++# set(_REDLAND_VERSION_OK)
+ message(STATUS "${_OUTPUT}")
+ message(STATUS "Redland with broken NEEDED section detected, disabling")
+ endif(NOT "${_TEST_EXITCODE}" EQUAL 0)
diff --git a/unmaintained/soprano/soprano-2.9.4-dbus-1.patch b/unmaintained/soprano/soprano-2.9.4-dbus-1.patch
new file mode 100755
index 0000000000..9861c6d2ed
--- /dev/null
+++ b/unmaintained/soprano/soprano-2.9.4-dbus-1.patch
@@ -0,0 +1,12 @@
+--- a/server/servercore.cpp
++++ b/server/servercore.cpp
+@@ -41,7 +41,9 @@
+ #include <QtNetwork/QTcpServer>
+ #include <QtNetwork/QHostAddress>
+ #include <QtNetwork/QTcpSocket>
++#ifdef BUILD_DBUS_SUPPORT
+ #include <QtDBus/QtDBus>
++#endif
+
+
+ const quint16 Soprano::Server::ServerCore::DEFAULT_PORT = 5000;