aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/spice-vdagent/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/spice-vdagent/APKBUILD
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/spice-vdagent/APKBUILD')
-rw-r--r--unmaintained/spice-vdagent/APKBUILD60
1 files changed, 60 insertions, 0 deletions
diff --git a/unmaintained/spice-vdagent/APKBUILD b/unmaintained/spice-vdagent/APKBUILD
new file mode 100644
index 0000000000..926f355e45
--- /dev/null
+++ b/unmaintained/spice-vdagent/APKBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=spice-vdagent
+pkgver=0.15.0
+pkgrel=1
+pkgdesc="Agent for Spice guests"
+url="http://spice-space.org/"
+arch="all"
+license="GPLv3+"
+depends=""
+depends_dev=""
+makedepends="$depends_dev glib-dev spice-protocol libpciaccess-dev dbus-dev
+ libxrandr-dev libxinerama-dev libxfixes-dev linux-headers"
+install=""
+subpackages="$pkgname-doc"
+source="http://spice-space.org/download/releases/spice-vdagent-$pkgver.tar.bz2
+ "$pkgname"d.initd
+ fix-memcpy-memset-implicit-declaration.patch
+ "
+
+_builddir="$srcdir"/spice-vdagent-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ install -m755 -D "$srcdir/$pkgname"d.initd \
+ "$pkgdir"/etc/init.d/"$pkgname"d || return 1
+}
+
+md5sums="2919ac7a4195b0b4b2588fae90a9241c spice-vdagent-0.15.0.tar.bz2
+038842701e8eb6a2890ecd97f34e9aab spice-vdagentd.initd
+083cdf808a24d1855d09a93a52dbeccd fix-memcpy-memset-implicit-declaration.patch"
+sha256sums="5bae1747307c2f4195f6de97639391be7c6be6c5673fdcc9febed6faca22bd34 spice-vdagent-0.15.0.tar.bz2
+0aab914c3f71d19452969c8bfae64e72bd970df3903e29602217a951e87c0db9 spice-vdagentd.initd
+69bbdffc46bd247f5fdee84e8a06d86b0a59e8dc53e9dc5eb0fd8055d87b9323 fix-memcpy-memset-implicit-declaration.patch"
+sha512sums="7d3bdeca2a8a5a63f817c8b0c1c46508e3238e0d2f3a018e44ffa4c7a2b7d0e82b0a2c37a6f35c59fcb23d89de82312edb689dc1de6fdf659004e640b900f436 spice-vdagent-0.15.0.tar.bz2
+0fc2b0a88b0d8707fa814da1b484888763f2bc51792568a38404a15ba88b4b37e4a9f54bc3452cc4605d0026c2af774bb689df6e56ca14b6fa48be5bc81c5705 spice-vdagentd.initd
+381f974580aa478a9c0a35d7e6cc5bee57903f47929dea143ee2ddda9952d4b3ed6180a2b2e90ef83b01425d46507ea18bba01c42d32739fd0cc85bcbac59537 fix-memcpy-memset-implicit-declaration.patch"