aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/stress
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/stress
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/stress')
-rw-r--r--unmaintained/stress/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/unmaintained/stress/APKBUILD b/unmaintained/stress/APKBUILD
new file mode 100644
index 0000000000..01e72936f6
--- /dev/null
+++ b/unmaintained/stress/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Andy Shinn <andys@andyshinn.as>
+pkgname=stress
+pkgver=1.0.4
+pkgrel=0
+pkgdesc="a deliberately simple workload generator for POSIX systems"
+url="http://people.seas.harvard.edu/~apw/stress/"
+arch="all"
+license="GPLv2"
+depends=
+depends_dev=
+makedepends="gcc make libc-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://people.seas.harvard.edu/~apw/$pkgname/$pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="890a4236dd1656792f3ef9a190cf99ef stress-1.0.4.tar.gz"
+sha256sums="057e4fc2a7706411e1014bf172e4f94b63a12f18412378fca8684ca92408825b stress-1.0.4.tar.gz"
+sha512sums="623a7d9585828bed4b7673e19fb0cfdda904552cd56353d74106047b64249299d5f8da892ec135f1781ec3984c7d5835dcc6c0d8e659e06c8a1e4fb2af9fd9c4 stress-1.0.4.tar.gz"