aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/subberthehut/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/subberthehut/APKBUILD
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/subberthehut/APKBUILD')
-rw-r--r--unmaintained/subberthehut/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/unmaintained/subberthehut/APKBUILD b/unmaintained/subberthehut/APKBUILD
new file mode 100644
index 0000000000..bd375d70d3
--- /dev/null
+++ b/unmaintained/subberthehut/APKBUILD
@@ -0,0 +1,26 @@
+# Maintainer:
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
+
+pkgname=subberthehut
+pkgver=17
+pkgrel=0
+pkgdesc='Command-line based OpenSubtitles.org downloader'
+arch=all
+url='https://github.com/mus65/subberthehut'
+license='GPL2'
+depends=
+makedepends='xmlrpc-c-dev glib-dev zlib-dev curl-dev bash-completion'
+source="https://github.com/mus65/$pkgname/archive/$pkgver.tar.gz"
+
+build() {
+ make -C "$srcdir"/$pkgname-$pkgver || return 1
+}
+
+package() {
+ make -C "$srcdir"/$pkgname-$pkgver DESTDIR="$pkgdir" PREFIX=/usr install \
+ || return 1
+}
+
+md5sums="a208bc658dce94d4b1696403a9d75e69 17.tar.gz"
+sha256sums="fde3137b9f818e02eda3e6d7bf444b02df50bf60bb817a672e3413464a816e14 17.tar.gz"
+sha512sums="24d5935ec88c38f00e8b2e060e8cf8c680b3a1488539e66a7df6611697611cef420fc74cce9d2530a76a5e1e9215d5ece8267160ba69f8d6e266d5b063bd783e 17.tar.gz"