aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/tb-tun
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/tb-tun
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/tb-tun')
-rw-r--r--unmaintained/tb-tun/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/unmaintained/tb-tun/APKBUILD b/unmaintained/tb-tun/APKBUILD
new file mode 100644
index 0000000000..676e981929
--- /dev/null
+++ b/unmaintained/tb-tun/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: Dennis Przytarski <dennis@przytarski.com>
+# Maintainer:
+pkgname=tb-tun
+pkgver=r18
+pkgrel=0
+pkgdesc="An userspace program using TUN/TAP to build 6to4/tunnelbroker/ISATAP tunnel on Linux"
+url="https://code.google.com/p/tb-tun/"
+arch="all"
+license="GPL1+ PerlArtistic"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages=""
+source="http://$pkgname.googlecode.com/files/${pkgname}_${pkgver}.tar.gz"
+
+_builddir="$srcdir"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ gcc tb_userspace.c -l pthread -o tb_userspace || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -Dm755 tb_userspace "$pkgdir"/usr/sbin/tb_userspace || return 1
+}
+
+md5sums="7227ed964e9eaacb7fc7e08a86c3ffcc tb-tun_r18.tar.gz"
+sha256sums="3c4a18069a888a15b20da3a8ba12374bcae8257b59c0f2221513811df23dec12 tb-tun_r18.tar.gz"
+sha512sums="476532ffaa0eb584af04bc226507445fbe6f5d50aff25cbee6f1d85c0fae19621923905be2a01c52bad5bb01156237b232eed485fd45ffee1da48f14534a92c0 tb-tun_r18.tar.gz"