aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/tidyhtml/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/tidyhtml/APKBUILD
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/tidyhtml/APKBUILD')
-rw-r--r--unmaintained/tidyhtml/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/unmaintained/tidyhtml/APKBUILD b/unmaintained/tidyhtml/APKBUILD
new file mode 100644
index 0000000000..596af37d55
--- /dev/null
+++ b/unmaintained/tidyhtml/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Valery Kartel <valery.kartel@gmail.com>
+# Contributor: Valery Kartel <valery.kartel@gmail.com>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
+
+pkgname=tidyhtml
+_pkgreal=tidy-html5
+pkgver=5.1.25
+pkgrel=0
+pkgdesc="Tool to tidy down your HTML code to a clean style"
+arch=all
+url="http://www.html-tidy.org"
+license="custom"
+depends=
+makedepends="cmake"
+subpackages="$pkgname-dev $pkgname-libs"
+source="$_pkgreal-$pkgver.tar.gz::https://codeload.github.com/htacg/$_pkgreal/tar.gz/$pkgver"
+
+_builddir="$srcdir"/$_pkgreal-$pkgver
+
+build(){
+ cd "$_builddir"
+ cmake CMakeLists.txt -DCMAKE_INSTALL_PREFIX=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="5fd96deef635ab8cea3dc74079f54d95 tidy-html5-5.1.25.tar.gz"
+sha256sums="be81e967537984fbd207b4b19d02e7be73cbf201f07bf55aa5560c9b1d19b106 tidy-html5-5.1.25.tar.gz"
+sha512sums="d58757858cdc41b064e6002d30ff5a7059dca9c4a25f4f8a7cb8ffbfc175b1bddc92c0f7139660872a86024e9d96797637872bc44dda1652d13dec883be296f8 tidy-html5-5.1.25.tar.gz"