aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/totem-pl-parser
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/totem-pl-parser
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/totem-pl-parser')
-rw-r--r--unmaintained/totem-pl-parser/APKBUILD44
-rw-r--r--unmaintained/totem-pl-parser/no-libsoup-gnome.patch31
2 files changed, 75 insertions, 0 deletions
diff --git a/unmaintained/totem-pl-parser/APKBUILD b/unmaintained/totem-pl-parser/APKBUILD
new file mode 100644
index 0000000000..b42850fcb7
--- /dev/null
+++ b/unmaintained/totem-pl-parser/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=totem-pl-parser
+pkgver=2.32.1
+pkgrel=3
+pkgdesc="playlist parsing library for totem"
+url="http://projects.gnome.org/totem"
+arch="all"
+license="LGPL"
+depends=
+depends_dev="glib-dev gmime-dev libsoup-dev libxml2-dev"
+makedepends="$depends_dev intltool autoconf automake libtool"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="ftp://ftp.gnome.org/pub/gnome/sources/${pkgname}/${pkgver%.*}/${pkgname}-${pkgver}.tar.bz2
+ no-libsoup-gnome.patch"
+
+_builddir="${srcdir}/${pkgname}-${pkgver}"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ autoconf
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --disable-scrollkeeper || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="2cedaab5dee14526ad0be0970155151f totem-pl-parser-2.32.1.tar.bz2
+2f4ec2e4e2f17338c96beb2b91e92cb3 no-libsoup-gnome.patch"
diff --git a/unmaintained/totem-pl-parser/no-libsoup-gnome.patch b/unmaintained/totem-pl-parser/no-libsoup-gnome.patch
new file mode 100644
index 0000000000..9f0770bd92
--- /dev/null
+++ b/unmaintained/totem-pl-parser/no-libsoup-gnome.patch
@@ -0,0 +1,31 @@
+Only in b: config.log
+--- a/configure.in
++++ b/configure.in
+@@ -60,7 +60,7 @@
+ AC_SUBST(TOTEM_PL_PARSER_VERSION_MINOR)
+ AC_SUBST(TOTEM_PL_PARSER_VERSION_MICRO)
+
+-pkg_modules="glib-2.0 >= $GLIB_REQS libxml-2.0 gthread-2.0 gio-2.0 >= $GIO_REQS libsoup-gnome-2.4"
++pkg_modules="glib-2.0 >= $GLIB_REQS libxml-2.0 gthread-2.0 gio-2.0 >= $GIO_REQS libsoup-2.4"
+
+ ##################################
+ # Checking libgmime dependency
+--- a/plparse/totem-pl-parser-podcast.c
++++ b/plparse/totem-pl-parser-podcast.c
+@@ -25,7 +25,7 @@
+ #include <glib.h>
+
+ #ifndef TOTEM_PL_PARSER_MINI
+-#include <libsoup/soup-gnome.h>
++#include <libsoup/soup.h>
+ #include "xmlparser.h"
+ #include "totem-pl-parser.h"
+ #include "totemplparser-marshal.h"
+@@ -579,7 +579,6 @@
+ GByteArray *data;
+
+ session = soup_session_sync_new_with_options (
+- SOUP_SESSION_ADD_FEATURE_BY_TYPE, SOUP_TYPE_GNOME_FEATURES_2_26,
+ SOUP_SESSION_ADD_FEATURE_BY_TYPE, SOUP_TYPE_CONTENT_DECODER,
+ SOUP_SESSION_USER_AGENT, "iTunes/7.4.1",
+ SOUP_SESSION_ACCEPT_LANGUAGE_AUTO, TRUE,