aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/triggerhappy
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/triggerhappy
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/triggerhappy')
-rw-r--r--unmaintained/triggerhappy/APKBUILD58
-rw-r--r--unmaintained/triggerhappy/triggerhappy.confd2
-rw-r--r--unmaintained/triggerhappy/triggerhappy.initd12
3 files changed, 72 insertions, 0 deletions
diff --git a/unmaintained/triggerhappy/APKBUILD b/unmaintained/triggerhappy/APKBUILD
new file mode 100644
index 0000000000..ebf23ce0c8
--- /dev/null
+++ b/unmaintained/triggerhappy/APKBUILD
@@ -0,0 +1,58 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=triggerhappy
+pkgver=0.3.4
+pkgrel=1
+pkgdesc="A lightweight hotkey daemon"
+url="https://github.com/wertarbyte/triggerhappy"
+arch="all"
+license="GPL"
+depends=""
+depends_dev=""
+makedepends="$depends_dev perl"
+install=""
+subpackages="$pkgname-doc"
+source="triggerhappy-$pkgver.tar.gz::https://github.com/wertarbyte/triggerhappy/archive/release/$pkgver.tar.gz
+ triggerhappy.initd
+ triggerhappy.confd
+ "
+
+_builddir="$srcdir"/triggerhappy-release-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ install -D udev/triggerhappy-udev.rules \
+ "$pkgdir"/etc/udev/rules.d/50-triggerhappy.rules \
+ || return 1
+ install -d "$pkgdir"/etc/triggerhappy/triggers.d || return 1
+ install triggerhappy.conf.examples \
+ "$pkgdir"/etc/triggerhappy/triggerhappy.conf || return 1
+ install -Dm755 "$srcdir"/triggerhappy.initd \
+ "$pkgdir"/etc/init.d/triggerhappy || return 1
+ install -Dm644 "$srcdir"/triggerhappy.confd \
+ "$pkgdir"/etc/conf.d/triggerhappy || return 1
+}
+
+md5sums="9719903899b3082e75a7ff6e9c00752d triggerhappy-0.3.4.tar.gz
+47d1f804b364758f8742f487926468b4 triggerhappy.initd
+b96c7efb0c27a2d598ebab9cb8dd5dd9 triggerhappy.confd"
+sha256sums="68001858df715527326850940a71690fda9d159ac73bed4a580fb7d2ffd61c83 triggerhappy-0.3.4.tar.gz
+3d02676adbe3df0a6517754f78480364284521c0c6637a46419131d02025c66b triggerhappy.initd
+1601b34ed30ec11293a353937669d030d811357fa2e0f5eb7ff04874daf91702 triggerhappy.confd"
+sha512sums="cf08554a41019019c1142368273dc781c840bb9de81b9a386b4debd34f37816bfe516077f7192779822aa5662b3fadd76a6ff141e7c038b65dd7f51e92135e4c triggerhappy-0.3.4.tar.gz
+b7521739335576f6bfc1c8a440cfe0b137862a07fae1138dcec2a082a8043dd9b64c54c64b62de06e06c0ee003c04e962a8c9be4f60d9ea3ca0898cfde4320a6 triggerhappy.initd
+5f31b9736e8ee8a7c8125dd5c14c4cdf515a6d57c36d04b9b1949cdb6150f25ef264ed8ee5e31f0d62de12db151df5aec9a325ff5d5b5ba0b3b7105c76cd07a0 triggerhappy.confd"
diff --git a/unmaintained/triggerhappy/triggerhappy.confd b/unmaintained/triggerhappy/triggerhappy.confd
new file mode 100644
index 0000000000..f449481e51
--- /dev/null
+++ b/unmaintained/triggerhappy/triggerhappy.confd
@@ -0,0 +1,2 @@
+# specify input device(s)
+#devices="/dev/input/event0"
diff --git a/unmaintained/triggerhappy/triggerhappy.initd b/unmaintained/triggerhappy/triggerhappy.initd
new file mode 100644
index 0000000000..ac707e927c
--- /dev/null
+++ b/unmaintained/triggerhappy/triggerhappy.initd
@@ -0,0 +1,12 @@
+#!/sbin/runscript
+
+: ${socket:=/var/run/thd.socket}
+: ${triggers:=/etc/triggerhappy/triggers.d}
+
+command=/usr/sbin/thd
+pidfile=/var/run/thd.pid
+command_args="--daemon --socket $socket --triggers $triggers $devices --pidfile $pidfile"
+
+depend() {
+ before udev
+}