aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/ttf-noto/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/ttf-noto/APKBUILD
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/ttf-noto/APKBUILD')
-rw-r--r--unmaintained/ttf-noto/APKBUILD94
1 files changed, 94 insertions, 0 deletions
diff --git a/unmaintained/ttf-noto/APKBUILD b/unmaintained/ttf-noto/APKBUILD
new file mode 100644
index 0000000000..4bb2715aa6
--- /dev/null
+++ b/unmaintained/ttf-noto/APKBUILD
@@ -0,0 +1,94 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=ttf-noto
+pkgver=2015.04.20
+pkgrel=0
+pkgdesc="Noto Sans family."
+url="http://www.google.com/get/noto/"
+arch="noarch"
+license="Apache"
+depends="fontconfig $pkgname-sans $pkgname-serif"
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-sans $pkgname-serif"
+# added fontconfig configuration from:
+# https://github.com/bohoomil/fontconfig-ultimate/tree/master/fontconfig_patches/fonts-settings
+source="$pkgname-$pkgver.zip::http://storage.googleapis.com/noto-website/pkgs/Noto-hinted.zip
+ 40-noto-arabic.conf
+ 45-noto-sans.conf
+ 45-noto-serif.conf
+ 90-non-tt-noto-sans-cjk.conf
+ 90-tt-noto-sans.conf
+ 90-tt-noto-serif.conf"
+
+_builddir="$srcdir"
+
+build() {
+ cd "$_builddir"
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+sans() {
+ pkgdesc="Noto Sans family sans version"
+ depends="fontconfig"
+ local fonts="NotoSans-Bold.ttf NotoSans-BoldItalic.ttf NotoSans-Italic.ttf NotoSans-Regular.ttf"
+ mkdir -p "$subpkgdir"/usr/share/fonts/$subpkgname \
+ "$subpkgdir"/etc/fonts/conf.avail \
+ "$subpkgdir"/etc/fonts/conf.d
+ for i in $fonts; do
+ install -m644 "$srcdir/$i" \
+ "$subpkgdir"/usr/share/fonts/$subpkgname/ || return 1
+ done
+ for j in "$srcdir"/*sans.conf; do
+ install -m644 "$j" \
+ "$subpkgdir"/etc/fonts/conf.avail/ || return 1
+ cd "$subpkgdir"/etc/fonts/conf.d
+ ln -sf /etc/fonts/conf.avail/${j##*/}
+ done
+
+}
+
+serif() {
+ pkgdesc="Noto Sans family serif version"
+ depends="fontconfig"
+ local fonts="NotoSerif-Bold.ttf NotoSerif-BoldItalic.ttf NotoSerif-Italic.ttf NotoSerif-Regular.ttf"
+ mkdir -p "$subpkgdir"/usr/share/fonts/$subpkgname \
+ "$subpkgdir"/etc/fonts/conf.avail \
+ "$subpkgdir"/etc/fonts/conf.d
+ for i in $fonts; do
+ install -m644 "$srcdir/$i" \
+ "$subpkgdir"/usr/share/fonts/$subpkgname/ || return 1
+ done
+ for j in "$srcdir"/*serif.conf; do
+ install -m644 "$j" \
+ "$subpkgdir"/etc/fonts/conf.avail/ || return 1
+ cd "$subpkgdir"/etc/fonts/conf.d
+ ln -sf /etc/fonts/conf.avail/${j##*/}
+ done
+
+}
+md5sums="077a9978839e37b29af710819fb17729 ttf-noto-2015.04.20.zip
+c0f76a250026e206c646464e0c737528 40-noto-arabic.conf
+6be22d72486852a72614753e1796db06 45-noto-sans.conf
+3952f646d177cbac4e9cd20825efa8eb 45-noto-serif.conf
+bca92e0434fd31776c9c2ca2811b7eec 90-non-tt-noto-sans-cjk.conf
+4dc806a20e58a82b85e3f2fb3c88db0d 90-tt-noto-sans.conf
+49668e735b35206c06435851af9101cf 90-tt-noto-serif.conf"
+sha256sums="f93415d4ac7954417ade8461ade32490ec91a2301c5ccf1f5b206382c3bc74c5 ttf-noto-2015.04.20.zip
+b1c92b3551958be19b9a42e86483b3541f11f2fe963df400b1bd6e6ea9957234 40-noto-arabic.conf
+2243a99616c04f8cd0696163d1e0290f2358e6a190c777d27fa1a5cd18092a70 45-noto-sans.conf
+57cbe8e58aabbe14b68a0d75f28688eb9fe6c80864d0baf5b300ab2b02c4fc25 45-noto-serif.conf
+38610c8c44ef29a280f4dbfd96458aeee8aa1381b9e460968cda093ce800cabd 90-non-tt-noto-sans-cjk.conf
+6b7457238150b44d1a2b747cc8130d563def2fd37e0a6786ab6f7b65f2c87f0d 90-tt-noto-sans.conf
+76cf5ee16843444849fcf6c69c5d021933644a4ed3689f7457470c9c351742de 90-tt-noto-serif.conf"
+sha512sums="240aab0cd1bb88e98c504bdd6bad680fc3e94c207f12d2c9f7a3de250aa2d6adc4bdbe7a4971e55930446b8f8cf079f84283deab5210d7519e2128d9a8961939 ttf-noto-2015.04.20.zip
+47396e7a4e5dfb38d3df6dff0b4584757cc132f393d3410463eefc3dbb5f2af592a6b07a4c098d8c594be03f23e4eb84b76b672245fe0cea816927cf535ea270 40-noto-arabic.conf
+748dfecbc3ad5c3750764e6ae889bbc4e614885237bb91ece138d2dc5014fd41ea6361b32982cfa4e76c7c092e0b93f90cccd0b92acbd408b7c302c44c1523e6 45-noto-sans.conf
+5059295a1c36c4ec4aae61443221ee74876315127895da0773e4feb77e70cfc4b7923dde8f6510d6cf9de019082e15f1f4fd4b53f0bce4d2a681541f2de587df 45-noto-serif.conf
+7cf1ec09d6226c46ff7bd796ff526aa42b7221eeb8a2e171e7dbab837fceb96a03b9c5d7bd6e88dbee97cdf54e443d940590b6be51478b88ebca19a419831080 90-non-tt-noto-sans-cjk.conf
+e5d252e4ee265f9cc7a91eea0e0f8c74315a60cbce606860e0f9e722eb9331f8d87d541dd715bef46bdb4e637bab0344f2fd98cc0424e7cfa17e588efa07eb33 90-tt-noto-sans.conf
+4f8760f7eeae99050a3b8ac73f4eeeb5ad32e9e5224034292e3ecdc260ffcc92f3ae45aa35e9f86905fce4ff909bb3263e25d8f4fe56dacba2fb3de2107e314f 90-tt-noto-serif.conf"