aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/ubus
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/ubus
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/ubus')
-rw-r--r--unmaintained/ubus/APKBUILD51
-rw-r--r--unmaintained/ubus/disable-systemd.patch11
2 files changed, 62 insertions, 0 deletions
diff --git a/unmaintained/ubus/APKBUILD b/unmaintained/ubus/APKBUILD
new file mode 100644
index 0000000000..58624854dd
--- /dev/null
+++ b/unmaintained/ubus/APKBUILD
@@ -0,0 +1,51 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=ubus
+pkgver=0_git20150919
+pkgrel=0
+pkgdesc="OpenWrt micro bus architecture"
+url="http://nbd.name/gitweb.cgi?p=luci2/ubus.git"
+arch="all"
+license="GPL"
+depends=
+depends_dev=
+makedepends="$depends_dev cmake json-c-dev libubox libubox-dev"
+subpackages="$pkgname-dev"
+install=
+source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.gz
+ disable-systemd.patch
+ "
+giturl="git://nbd.name/luci2/ubus.git"
+disturl="dev.alpinelinux.org:/archive/$pkgname"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch)
+ msg "Applying $i"
+ patch -p1 -i "$srcdir"/$i || return 1
+ ;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ cmake CMakeLists.txt -DBUILD_LUA=OFF -DCMAKE_INSTALL_PREFIX=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="8697350a75ba8f6b4c9d27ec1a0a30f3 ubus-0_git20150919.tar.gz
+335d57ca38e7cd6ec69433a13c0381fa disable-systemd.patch"
+sha256sums="b7a89410a5bb6e219e65027e641c043dab8d1a0f658d5c7da5f9704b59106924 ubus-0_git20150919.tar.gz
+1232e614b2f3e26687e380c952901833e1bf3e179ba78f14a7bdebb3856a2cec disable-systemd.patch"
+sha512sums="903483208ae5d303e9436f3aa315ad2603ca4c835832470e78a6e0502e889dab02af7d34f624fd9659d1e9679fc0a8724d1223aa7e8d0a9864c109d0de09a496 ubus-0_git20150919.tar.gz
+bef2a9892290b8b37a3b1db414a8031e43823a023660648f06effe3d3ed0258e1f6f7433e59bc46436237bec2cf0a0e7af6d6105d76c1f289a1496bb39f55480 disable-systemd.patch"
diff --git a/unmaintained/ubus/disable-systemd.patch b/unmaintained/ubus/disable-systemd.patch
new file mode 100644
index 0000000000..1a0641e82c
--- /dev/null
+++ b/unmaintained/ubus/disable-systemd.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -5,7 +5,7 @@
+
+ OPTION(BUILD_LUA "build Lua plugin" ON)
+ OPTION(BUILD_EXAMPLES "build examples" ON)
+-OPTION(ENABLE_SYSTEMD "systemd support" ON)
++OPTION(ENABLE_SYSTEMD "systemd support" OFF)
+
+ SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")
+ SET(UBUS_UNIX_SOCKET "/var/run/ubus.sock")