aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/uci
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/uci
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/uci')
-rw-r--r--unmaintained/uci/APKBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/unmaintained/uci/APKBUILD b/unmaintained/uci/APKBUILD
new file mode 100644
index 0000000000..bb4199bd1f
--- /dev/null
+++ b/unmaintained/uci/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=uci
+pkgver=0_git20150919
+pkgrel=1
+pkgdesc="Library and utility for the Unified Configuration Interface for OpenWrt"
+url="http://nbd.name/gitweb.cgi?p=uci.git"
+arch="all"
+license="GPL"
+depends=
+depends_dev=
+makedepends="$depends_dev cmake libubox-dev libubox"
+subpackages="$pkgname-dev"
+install=
+source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.gz
+ "
+giturl="git://nbd.name/uci.git"
+disturl="dev.alpinelinux.org:/archive/$pkgname"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch)
+ msg "Applying $i"
+ patch -p1 -i "$srcdir"/$i || return 1
+ ;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ cmake CMakeLists.txt -DBUILD_LUA=OFF -DCMAKE_INSTALL_PREFIX=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ class="western"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="d50257b0adedc8fb82a3b90f43830adc uci-0_git20150919.tar.gz"
+sha256sums="5d91c0c80e9bc14b85cdc2f622e2c0c8e1c2ba20a1e7d496cd49536b135c0479 uci-0_git20150919.tar.gz"
+sha512sums="8c2d9fe4492be3231049ab8899ac232b663f31c73a5c857f92d77eccdf3a3bd83967b611cc59b1f507449e030487eb3511214229aa257f426afc72463ed211f7 uci-0_git20150919.tar.gz"