aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/ucspi-ssl
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/ucspi-ssl
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/ucspi-ssl')
-rw-r--r--unmaintained/ucspi-ssl/0001-Add-missing-make-targets.patch41
-rw-r--r--unmaintained/ucspi-ssl/APKBUILD70
2 files changed, 111 insertions, 0 deletions
diff --git a/unmaintained/ucspi-ssl/0001-Add-missing-make-targets.patch b/unmaintained/ucspi-ssl/0001-Add-missing-make-targets.patch
new file mode 100644
index 0000000000..8c36dab94c
--- /dev/null
+++ b/unmaintained/ucspi-ssl/0001-Add-missing-make-targets.patch
@@ -0,0 +1,41 @@
+From a4f0a53cab0caa35607a85378bc687468eaec466 Mon Sep 17 00:00:00 2001
+From: Jesse Young <jlyo@jlyo.org>
+Date: Fri, 24 Jul 2015 16:11:59 +0000
+Subject: [PATCH] Add missing make targets
+
+---
+ host/superscript.com/net/ucspi-ssl-0.95b/src/Makefile | 11 +++++++++++
+ 1 file changed, 11 insertions(+)
+
+diff --git a/host/superscript.com/net/ucspi-ssl-0.95b/src/Makefile b/host/superscript.com/net/ucspi-ssl-0.95b/src/Makefile
+index 452586c..089b1ff 100755
+--- a/host/superscript.com/net/ucspi-ssl-0.95b/src/Makefile
++++ b/host/superscript.com/net/ucspi-ssl-0.95b/src/Makefile
+@@ -454,6 +454,12 @@ compile remoteinfo.c buffer.h error.h fmt.h gen_alloc.h iopause.h \
+ remoteinfo.h socket.h stralloc.h tai.h taia.h timeoutconn.h uint16.h uint64.h
+ ./compile remoteinfo.c
+
++remoteinfo6.o: \
++compile remoteinfo6.c buffer.h error.h fmt.h gen_alloc.h iopause.h \
++remoteinfo.h socket.h stralloc.h tai.h taia.h timeoutconn.h uint16.h uint32.h \
++uint64.h
++ ./compile remoteinfo6.c
++
+ rules.o: \
+ compile rules.c alloc.h cdb.h gen_alloc.h ip4_bit.h open.h rules.h \
+ str.h stralloc.h uint32.h
+@@ -881,6 +887,11 @@ compile timeoutconn.c error.h iopause.h ndelay.h socket.h tai.h \
+ taia.h timeoutconn.h uint16.h uint64.h
+ ./compile timeoutconn.c
+
++timeoutconn6.o: \
++compile timeoutconn6.c error.h iopause.h ndelay.h socket.h \
++tai.h taia.h timeoutconn.h uint16.h uint32.h uint64.h
++ ./compile timeoutconn6.c
++
+ ucspissl.a: \
+ makelib ssl_ca.o ssl_cca.o ssl_certkey.o ssl_chainfile.o ssl_ciphers.o \
+ ssl_context.o ssl_env.o ssl_error.o ssl_io.o ssl_new.o ssl_params.o ssl_timeoutaccept.o \
+--
+2.4.6
+
diff --git a/unmaintained/ucspi-ssl/APKBUILD b/unmaintained/ucspi-ssl/APKBUILD
new file mode 100644
index 0000000000..7e0a601ae4
--- /dev/null
+++ b/unmaintained/ucspi-ssl/APKBUILD
@@ -0,0 +1,70 @@
+# Contributor: Jesse Young <jlyo@jlyo.org>
+# Maintainer:
+pkgname=ucspi-ssl
+pkgver=0.95b
+pkgrel=0
+pkgdesc="Command-line tools for building SSL client-server applications"
+url="http://www.fehcom.de/ipnet/ucspi-ssl.html"
+arch="all"
+license="public-domain"
+depends=""
+depends_dev=""
+makedepends="$depends_dev openssl-dev linux-headers perl-dev"
+install=""
+#subpackages="$pkgname-doc"
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://www.fehcom.de/ipnet/${pkgname}/${pkgname}-${pkgver}.tgz
+ 0001-Add-missing-make-targets.patch"
+
+_builddir="${srcdir}/host/superscript.com/net/${pkgname}-${pkgver}"
+prepare() {
+ local i
+ cd "$srcdir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "${_builddir}/src"
+
+ echo "${CC:-"gcc"} ${CFLAGS}" > conf-cc
+ echo "${CC:-"gcc"} ${LDFLAGS}" > conf-ld
+ echo "/usr" > home
+
+ make || return 1
+}
+
+package() {
+ local f
+ cd "$_builddir"
+ mkdir -p "$pkgdir"/usr/bin
+ for f in $(cat package/commands-base); do
+ cp "src/${f}" "${pkgdir}/usr/bin/${f}"
+ done
+
+ for f in $(cd man && echo *.[0-9] ); do
+ mkdir -p "${pkgdir}/usr/share/man/man${f##*[a-zA-Z.]}"
+ cp "man/${f}" "${pkgdir}/usr/share/man/man${f##*[a-zA-Z.]}/${f}"
+ done
+}
+
+dev() {
+ default_dev
+ cd "$_builddir"
+
+ mkdir -p "${subpkgdir}/usr/include/${pkgname}"
+ mkdir -p "${subpkgdir}/usr/lib/${pkgname}"
+ install -m644 "src/ucspissl.a" "${subpkgdir}/usr/lib/${pkgname}/ucspissl.a"
+ install -m644 "src/ucspissl.h" "${subpkgdir}/usr/include/${pkgname}/ucspissl.h"
+ install -m644 "src/ssl.lib" "${subpkgdir}/usr/lib/${pkgname}/ssl.lib"
+}
+
+md5sums="a9fd37da2dd68861a3ff6bb9f1589364 ucspi-ssl-0.95b.tgz
+f98c590f3dbde7d616d9909bf3fc044b 0001-Add-missing-make-targets.patch"
+sha256sums="9f3bcf66546b433b089f6f340d243065beb801b97d4026e54dd586f0022b5f1e ucspi-ssl-0.95b.tgz
+10964e922af5f2cadb4712091ff389ad33270e834658a711e8f912df4dd822e9 0001-Add-missing-make-targets.patch"
+sha512sums="686bd4a1e4b9d560b381eb78193351114ef4135638296b9287db2fa168ba223412fb377aebbcbaa01a084bcc32455e69787ca3478bea248fed68dc5b882d8861 ucspi-ssl-0.95b.tgz
+dba8942c9e047b7d077a4561e6ca929ed9962250c6f8dd15c1bd3a4dfceb73a54a76963b7c3b4b63afc105bc208f06f602f4049515f176dc33fc2478f6acdc42 0001-Add-missing-make-targets.patch"