aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/ucspi-tcp6
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/ucspi-tcp6
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/ucspi-tcp6')
-rw-r--r--unmaintained/ucspi-tcp6/APKBUILD58
1 files changed, 58 insertions, 0 deletions
diff --git a/unmaintained/ucspi-tcp6/APKBUILD b/unmaintained/ucspi-tcp6/APKBUILD
new file mode 100644
index 0000000000..a9535a4d59
--- /dev/null
+++ b/unmaintained/ucspi-tcp6/APKBUILD
@@ -0,0 +1,58 @@
+# Contributor: Jesse Young <jlyo@jlyo.org>
+# Maintainer:
+pkgname=ucspi-tcp6
+pkgver=1.00a
+pkgrel=0
+pkgdesc="IPv6 enabled ucspi-tcp superserver"
+url="http://www.fehcom.de/ipnet/ucspi-tcp6.html"
+arch="all"
+license="public-domain"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+conflicts="ucspi-tcp"
+provides="ucspi-tcp"
+source="http://www.fehcom.de/ipnet/${pkgname}/${pkgname}-${pkgver}.tgz"
+
+_builddir="${srcdir}/host/${pkgname}-${pkgver%%[a-zA-Z]}"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "${_builddir}/src"
+
+ echo "${CC:-"gcc"} ${CFLAGS}" > conf-cc
+ echo "${CC:-"gcc"} ${LDFLAGS}" > conf-ld
+ echo "/usr" > home
+
+ make || return 1
+}
+
+package() {
+ local f
+ cd "$_builddir"
+ mkdir -p "$pkgdir"/usr/bin
+ for f in $(cat package/commands-base); do
+ cp "src/${f}" "${pkgdir}/usr/bin/${f}"
+ done
+
+ for f in $(cd man && echo *.[0-9] ); do
+ mkdir -p "${pkgdir}/usr/share/man/man${f##*[a-zA-Z.]}"
+ cp "man/${f}" "${pkgdir}/usr/share/man/man${f##*[a-zA-Z.]}/${f}"
+ done
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+ cp doc/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+md5sums="24909412ef7d7ecb32cf3132989b78ea ucspi-tcp6-1.00a.tgz"
+sha256sums="b0f6df425c2f3e90c89a94c501414834ea1bc0b66b8ba381fda8ca02f25d1608 ucspi-tcp6-1.00a.tgz"
+sha512sums="94c623721d19d047aed4fbffbf2702f51588426d0689102478c98bc91ca1f60f65d493dcad3681db63f231ea811dad2c1c7c7c6ead45d40a490f743212c10908 ucspi-tcp6-1.00a.tgz"