aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/unagi/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/unagi/APKBUILD
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/unagi/APKBUILD')
-rw-r--r--unmaintained/unagi/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/unmaintained/unagi/APKBUILD b/unmaintained/unagi/APKBUILD
new file mode 100644
index 0000000000..9da0cbd2c8
--- /dev/null
+++ b/unmaintained/unagi/APKBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=unagi
+pkgver=0.3.3
+pkgrel=1
+pkgdesc="A modular compositing manager"
+url="https://projects.mini-dweeb.org/projects/unagi"
+arch="all"
+license="GPLv3"
+depends=""
+depends_dev="libxdg-basedir-dev libxcb-dev confuse-dev xcb-util-wm-dev
+ xcb-util-keysyms-dev xcb-util-renderutil-dev xcb-util-image-dev
+ libev-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev"
+source="https://projects.mini-dweeb.org/attachments/download/111/unagi-$pkgver.tar.gz"
+
+_builddir="$srcdir"/unagi-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ || return 1
+ make || return
+}
+
+package() {
+ cd "$_builddir"
+ make install DESTDIR="$pkgdir" || return 1
+}
+
+md5sums="4a1bc93d23cbbafc87aa0c7f956a585c unagi-0.3.3.tar.gz"