aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/unibilium/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/unibilium/APKBUILD
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/unibilium/APKBUILD')
-rw-r--r--unmaintained/unibilium/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/unmaintained/unibilium/APKBUILD b/unmaintained/unibilium/APKBUILD
new file mode 100644
index 0000000000..71a09780bd
--- /dev/null
+++ b/unmaintained/unibilium/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Marvin Steadfast <marvin@xsteadfastx.org>
+# Maintainer: Marvin Steadfast <marvin@xsteadfastx.org>
+pkgname=unibilium
+pkgver=1.2.0
+pkgrel=0
+pkgdesc="A terminfo parsing library"
+url="https://github.com/mauke/unibilium/"
+arch="all"
+license="LGPL3"
+depends=""
+depends_dev="libtool"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/mauke/unibilium/archive/v$pkgver.tar.gz"
+
+_builddir="$srcdir"/"$pkgname"-"$pkgver"
+build() {
+ cd "$_builddir"
+ make PREFIX=/usr || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make PREFIX=/usr DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="9b1c97839a880a373da6c097443b43c4 unibilium-1.2.0.tar.gz"
+sha256sums="623af1099515e673abfd3cae5f2fa808a09ca55dda1c65a7b5c9424eb304ead8 unibilium-1.2.0.tar.gz"
+sha512sums="7aff79669200810c2910006aba657ca2276123ecb3e6e0ba01fa2d1c3cdf838c391594e6035ef150deb6185c4f1e43fe1b0bfb59b23c6697d801a5bdee37a0ee unibilium-1.2.0.tar.gz"