aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/unifdef
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/unifdef
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/unifdef')
-rw-r--r--unmaintained/unifdef/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/unmaintained/unifdef/APKBUILD b/unmaintained/unifdef/APKBUILD
new file mode 100644
index 0000000000..7b98629ab0
--- /dev/null
+++ b/unmaintained/unifdef/APKBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=unifdef
+pkgver=2.10
+pkgrel=0
+pkgdesc="Tool to process C preprocessor #if and #ifdef directives"
+url="http://dotat.at/prog/unifdef/"
+arch="all"
+license="BSD"
+depends=""
+depends_dev=""
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://dotat.at/prog/unifdef/unifdef-$pkgver.tar.xz"
+
+_builddir="$srcdir"/unifdef-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make prefix=/usr || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" prefix=/usr install || return 1
+}
+
+md5sums="bb5d895e5ebbba5c5cc0c2771cf97ebe unifdef-2.10.tar.xz"
+sha256sums="3b9b2b6b1952e9b9c1b9f734edec270689a35bdbf33ae66b50e19b2ed0d2df06 unifdef-2.10.tar.xz"
+sha512sums="9537a4679997a2677dcbe26c5849147654eb20b9edbf7625bd251e065d90a3ea54c4be9d445abdbc611820d8902d446062f800313904ac3f9cde3a89120860de unifdef-2.10.tar.xz"