aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/unpaper/APKBUILD
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/unpaper/APKBUILD
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/unpaper/APKBUILD')
-rw-r--r--unmaintained/unpaper/APKBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/unmaintained/unpaper/APKBUILD b/unmaintained/unpaper/APKBUILD
new file mode 100644
index 0000000000..bdda5bafcd
--- /dev/null
+++ b/unmaintained/unpaper/APKBUILD
@@ -0,0 +1,51 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=unpaper
+pkgver=6.1
+pkgrel=0
+pkgdesc="post-processing tool for scanned sheets of paper"
+url="https://github.com/Flameeyes/unpaper"
+arch="all"
+license="GPL"
+depends=""
+depends_dev="ffmpeg-dev"
+makedepends="$depends_dev automake autoconf libtool libxslt"
+install=""
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/Flameeyes/unpaper/tarball/unpaper-$pkgver"
+
+_builddir="$srcdir/Flameeyes-unpaper-5e7fdc7"
+
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ aclocal && automake --add-missing && autoconf
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="ade1513be12ffc73063db0b375017ca7 unpaper-6.1.tar.gz"
+sha256sums="9421fa66c8506f12dc0cc4c3814f1b41903420f6afeecd0db50fae49fcdb5740 unpaper-6.1.tar.gz"
+sha512sums="96e4f5748f836044d47a08b5c61f4367c8497d64b61e588a38b11ae99261a051c2c77e61aef85803dcd904aa8b03d78a5fa1c467bb3e632dbe9dbd68c4719557 unpaper-6.1.tar.gz"