aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/upgrade-notify
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-12-01 17:26:53 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-12-01 17:26:53 +0100
commit3ce3c4fd596debefbad77328a9b62a39eccf753c (patch)
tree8ea8842d946335dbd124e71336a11b928481c544 /unmaintained/upgrade-notify
parent62b8ba5f8fe6d62d56b2d078b4f12f72830ee4af (diff)
downloadaports-3ce3c4fd596debefbad77328a9b62a39eccf753c.tar.bz2
aports-3ce3c4fd596debefbad77328a9b62a39eccf753c.tar.xz
unmaintained/*: purge aports not touched since v3.5.0
We agreed with ncopa on #alpine-devel (2017-12-01 16:20 UTC) to periodically purge aports in unmaintained that haven't been touched in last 1 year (2 releases).
Diffstat (limited to 'unmaintained/upgrade-notify')
-rw-r--r--unmaintained/upgrade-notify/APKBUILD19
-rw-r--r--unmaintained/upgrade-notify/upgrade-notify.trigger52
2 files changed, 0 insertions, 71 deletions
diff --git a/unmaintained/upgrade-notify/APKBUILD b/unmaintained/upgrade-notify/APKBUILD
deleted file mode 100644
index 901907b1aa..0000000000
--- a/unmaintained/upgrade-notify/APKBUILD
+++ /dev/null
@@ -1,19 +0,0 @@
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname="upgrade-notify"
-pkgver=0.1
-pkgrel=0
-license="GPL"
-pkgdesc="Get notifications about what services need to restart after an upgrade"
-url="http://git.alpinelinux.org/alpine/tree/testing/upgrade-notify"
-arch=noarch
-triggers="$pkgname.trigger=/etc/init.d:/boot"
-
-build() {
- return 0
-}
-
-package() {
- mkdir -p "$pkgdir"
-}
-
-
diff --git a/unmaintained/upgrade-notify/upgrade-notify.trigger b/unmaintained/upgrade-notify/upgrade-notify.trigger
deleted file mode 100644
index 0c3cf462f8..0000000000
--- a/unmaintained/upgrade-notify/upgrade-notify.trigger
+++ /dev/null
@@ -1,52 +0,0 @@
-#!/bin/sh
-
-msg() {
- local summary="$1"
- shift
- echo "" >&2
- echo " $summary" >&2
- local i
- for i; do
- echo " $i" >&2
- done
- echo "" >&2
-}
-
-# compare the timestamp of "started" symlink with timestamp of /etc/init.d
-# if the /etc/init.d/* script is newer than "started" symlink then
-# service was upgraded after service was started
-services=$(find /run/openrc/started -type l | xargs stat -c "%n %Y" \
- | while read file started; do
- svc=${file##*/}
- installed=$(stat -c "%Y" /etc/init.d/$svc)
- if [ $installed -gt $started ]; then
- echo $svc
- fi
-done)
-
-need_reboot=false
-for i; do
- case $i in
- /boot)
- need_reboot=true
- esac
-done
-
-notify=msg
-if which notify-send > /dev/null; then
- notify="notify-send"
-fi
-
-if [ -n "$services" ]; then
- $notify "The following services have been updated and need a restart:" \
- $services
-fi
-
-case "$(rc --sys)" in
- LXC|VSERVER) exit 0 ;;
-esac
-
-if $need_reboot ; then
- $notify "Kernel(s) were updated. You might need to reboot"
-fi
-