aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/uselessd
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/uselessd
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/uselessd')
-rw-r--r--unmaintained/uselessd/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/unmaintained/uselessd/APKBUILD b/unmaintained/uselessd/APKBUILD
new file mode 100644
index 0000000000..bcddb44ffd
--- /dev/null
+++ b/unmaintained/uselessd/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=uselessd
+pkgver=7
+pkgrel=0
+pkgdesc="A systemd replacement which uses less"
+url="http://uselessd.darknedgy.net/"
+arch="all"
+license="GPL2 MIT"
+depends=""
+depends_dev="libcap-dev dbus-dev"
+makedepends="$depends_dev intltool gperf coreutils m4 docbook-xsl"
+install=""
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://bitbucket.org/bcsd/uselessd/downloads/uselessd-$pkgver.tar.xz"
+
+_builddir="$srcdir"/uselessd-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ --disable-nls \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="4e135a6c43fbd79c15e90a561f50c77d uselessd-7.tar.xz"
+sha256sums="35da6ce84b27147b10d6d5a224c94308f28b52bb3f0e993b3ed9ac7a0792b090 uselessd-7.tar.xz"
+sha512sums="465f6a01beb58cec8e884ca29c7f98a9a531f850f829bdbf441a415688398810bef029c1b1058bb64197d47b808d108b1a7eb1c9da8325afe87b77fa494d9190 uselessd-7.tar.xz"