aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/vdr-plugin-satip
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/vdr-plugin-satip
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/vdr-plugin-satip')
-rw-r--r--unmaintained/vdr-plugin-satip/APKBUILD46
-rw-r--r--unmaintained/vdr-plugin-satip/include-ctype-header.patch10
2 files changed, 56 insertions, 0 deletions
diff --git a/unmaintained/vdr-plugin-satip/APKBUILD b/unmaintained/vdr-plugin-satip/APKBUILD
new file mode 100644
index 0000000000..a6aabace4e
--- /dev/null
+++ b/unmaintained/vdr-plugin-satip/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer:
+pkgname=vdr-plugin-satip
+pkgver=0.3.3
+pkgrel=0
+pkgdesc="SAT>IP plugin for VDR"
+url="http://www.saunalahti.fi/~rahrenbe/vdr/satip/"
+arch="all"
+license="GPL"
+depends=""
+depends_dev="tinyxml-dev curl-dev vdr-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-lang"
+source="http://www.saunalahti.fi/~rahrenbe/vdr/satip/files/vdr-satip-$pkgver.tgz
+ include-ctype-header.patch"
+
+_builddir="$srcdir"/satip-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ #pugixml has pic issues
+ export SATIP_USE_TINYXML=1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="2f149747a512b47d32279dae0b6d3c75 vdr-satip-0.3.3.tgz
+a99d9d1d2e9ed2c5bbe0c7a35626a556 include-ctype-header.patch"
+sha256sums="10fff3a660ea57344c0c84d8e743aa5e23e653149c03621358a0d18a12eefd88 vdr-satip-0.3.3.tgz
+f900cd6eecdeb4a59d8bdb0165a27f6aa068a5cc53f941ad7f0724a751dedf53 include-ctype-header.patch"
+sha512sums="9851c635351746a85047e788a7522526f49a971cc009e7ff8f9c2648ccec60999d6336a6ce60b57ff480abcace9551ef5d4a855253c1647064670620c105aeaa vdr-satip-0.3.3.tgz
+56a6beef683248508cf571db8dc541ff09ae2a96e628ae0ecf0cb263c269a0d94eb2b0e107a331ca5e185205298b26e5a41eecfe27caca92ae4e178639165254 include-ctype-header.patch"
diff --git a/unmaintained/vdr-plugin-satip/include-ctype-header.patch b/unmaintained/vdr-plugin-satip/include-ctype-header.patch
new file mode 100644
index 0000000000..e884f6cc6a
--- /dev/null
+++ b/unmaintained/vdr-plugin-satip/include-ctype-header.patch
@@ -0,0 +1,10 @@
+--- a/satip.c
++++ b/satip.c
+@@ -6,6 +6,7 @@
+ */
+
+ #include <getopt.h>
++#include <ctype.h>
+ #include <vdr/plugin.h>
+ #include "common.h"
+ #include "config.h"