aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/waf
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/waf
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/waf')
-rw-r--r--unmaintained/waf/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/unmaintained/waf/APKBUILD b/unmaintained/waf/APKBUILD
new file mode 100644
index 0000000000..d4d8ff4cc8
--- /dev/null
+++ b/unmaintained/waf/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Valery Kartel <valery.kartel@gmail.com>
+# Maintainer: Valery Kartel <valery.kartel@gmail.com>
+pkgname=waf
+pkgver=1.8.16
+pkgrel=0
+pkgdesc="Python-based meta build system"
+url="https://waf.io/"
+arch="noarch"
+license="BSD"
+depends="python"
+makedepends="python unzip"
+subpackages=""
+source="https://waf.io/$pkgname-$pkgver.tar.bz2"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$_builddir"
+ ./waf-light configure --prefix=/usr build \
+ --make-waf \
+ --tools='compat,compat15,ocaml,go,cython,scala,erlang,cuda,gcj,boost,pep8,eclipse' \
+ || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -Dm755 waf "$pkgdir"/usr/bin/waf
+ local _rev=$(grep '^REVISION="[[:xdigit:]]*"$' "$pkgdir"/usr/bin/waf | cut -d\" -f2)
+ local _lib="$pkgdir"/usr/lib/$pkgname-$pkgver-$_rev
+ install -dm755 "$_lib"
+ unzip -d "$_lib" zip/waflib.zip
+ python -m compileall "$_lib"
+}
+
+md5sums="c68227e4d40c0bdd0aadab22a7a27a44 waf-1.8.16.tar.bz2"
+sha256sums="5188b5a4246ba3c7a2abbf4ddcb3b3457430166244035bf3c70036fb08944846 waf-1.8.16.tar.bz2"
+sha512sums="128484b9cdcd9f2aacdf089b20af016b2ddd862423dab537416b10ad8c8470202b0a9ab02c862be5fc11f73e24b98650e89e6808a3f9fd1f2a4e281fae3843e1 waf-1.8.16.tar.bz2"