aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/wbox
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/wbox
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/wbox')
-rw-r--r--unmaintained/wbox/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/unmaintained/wbox/APKBUILD b/unmaintained/wbox/APKBUILD
new file mode 100644
index 0000000000..a485a77ec5
--- /dev/null
+++ b/unmaintained/wbox/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=wbox
+pkgver=5
+pkgrel=0
+pkgdesc="HTTP testing tool and configuration-less HTTP server"
+url="http://www.hping.org/wbox/"
+arch="all"
+license="BSD"
+depends=""
+depends_dev=""
+makedepends=""
+install=""
+subpackages=""
+source="http://www.hping.org/wbox/$pkgname-$pkgver.tar.gz"
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -m755 -D "$_builddir"/$pkgname "$pkgdir"/usr/bin/$pkgname
+}
+
+md5sums="a95ca2c69982db10704b5ed482c9c722 wbox-5.tar.gz"
+sha256sums="1589d85e83c8ee78383a491d89e768ab9aab9f433c5f5e035cfb5eed17efaa19 wbox-5.tar.gz"
+sha512sums="cf652ae48a79f48d6f7530a14d7d2eddd4d3a925ef56c547312546bb41c2bbc75156783ff35fe6f079b52aa6090db3a9d6703f5e98f65117c7a161c4437f009b wbox-5.tar.gz"