aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained/xbattmon
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-25 15:26:24 +0200
commitb6af1e02efe594039707cd882517663d5370f375 (patch)
treeff9c2d55873e051e82972ba64c017352d3a75d34 /unmaintained/xbattmon
parenta71346b7acebc600960a98c84fb32cfd72fe864b (diff)
downloadaports-b6af1e02efe594039707cd882517663d5370f375.tar.bz2
aports-b6af1e02efe594039707cd882517663d5370f375.tar.xz
testing/[multiple]: move unmaintained packages
This moves all packages from testing to unmaintained which have not been updated for atleast 6 months. If you are affected by this commit please follow this proceddure: * make sure your packages build on all architectures * move your pacakge(s) back to testing * if you want to keep this package and can maintain it (or find somebody to maintain it for you) for a minimum of 6 months ask it to be moved to community
Diffstat (limited to 'unmaintained/xbattmon')
-rw-r--r--unmaintained/xbattmon/APKBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/unmaintained/xbattmon/APKBUILD b/unmaintained/xbattmon/APKBUILD
new file mode 100644
index 0000000000..23d01bffa3
--- /dev/null
+++ b/unmaintained/xbattmon/APKBUILD
@@ -0,0 +1,40 @@
+# Contributor: sin <sin@2f30.org>
+# Maintainer: sin <sin@2f30.org>
+pkgname=xbattmon
+pkgver=0.7
+pkgrel=0
+pkgdesc="a simple battery monitor"
+url="http://git.2f30.org/xbattmon"
+arch="all"
+license="ISC"
+depends=""
+depends_dev=""
+makedepends="$depends_dev libx11-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://dl.2f30.org/releases/xbattmon-$pkgver.tar.gz"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make PREFIX=/usr DESTDIR="$pkgdir" install || return 1
+}
+md5sums="534fd62ee1807795e0d8922e32d3f51f xbattmon-0.7.tar.gz"
+sha256sums="01ff252a431f00e86215a01a8864dc1a65595aaccf2d5fce25911b55f1e5115e xbattmon-0.7.tar.gz"
+sha512sums="e12e21aa56b9e1efd28b8a175a420fb3a6dae15926757a12f8769b9349f60479cef60a1b23360d7dee1999c9d27c71611c0dd9755d769adcfc39ac049bd8d942 xbattmon-0.7.tar.gz"