aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-31 02:29:15 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-31 02:29:16 -0300
commit4b243a0400b30c2eaafc023b884e50ec4b5fa2bc (patch)
tree9168c5adfe1d8cfd6ad42228cacf6aa36f2cfffb /unmaintained
parent61c8c5cadcf4294e5fd2c7d37d20907822962fe7 (diff)
downloadaports-4b243a0400b30c2eaafc023b884e50ec4b5fa2bc.tar.bz2
aports-4b243a0400b30c2eaafc023b884e50ec4b5fa2bc.tar.xz
unmaintained/py-napalm: move from testing
- Has lots of dependencies, none of which are declared, some of which are not even packaged.
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/py-napalm/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/unmaintained/py-napalm/APKBUILD b/unmaintained/py-napalm/APKBUILD
new file mode 100644
index 0000000000..cac905715e
--- /dev/null
+++ b/unmaintained/py-napalm/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=py-napalm
+pkgver=2.3.3
+pkgrel=1
+pkgdesc="Network Automation and Programmability Abstraction Layer with Multivendor support"
+url="https://github.com/napalm-automation/napalm"
+arch="noarch"
+license="Apache-2.0"
+depends=""
+makedepends="python2-dev python3-dev py-setuptools py2-pip"
+options="!check" #no testsuite
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="$pkgname-$pkgver.tar.gz::https://github.com/napalm-automation/napalm/archive/$pkgver.tar.gz"
+builddir="$srcdir"/napalm-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py --quiet build
+ python3 setup.py --quiet build
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"/usr/bin
+}
+
+_py2() {
+ depends="${depends//py-/py2-}"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-}"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ local pyver="${1:6:1}"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py --quiet install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="5eb87a00da81101e8ea3d8994ebfacd2d976328dfd2b7dbc7f2d90b8a6710c97def348bddede1164534edb24e51e0de56ecc3ed92029da36be4bbb3515cfd835 py-napalm-2.3.3.tar.gz"