aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-30 00:52:02 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-30 00:52:02 +0000
commit3f354e53c053b41e775a8a88d7b1bef9cec205f6 (patch)
treecb4aba6007f09b063dd4edb2e794e39127ebe8cd /unmaintained
parent23d00acb33e9362b2ba5f810a03815a275876340 (diff)
downloadaports-3f354e53c053b41e775a8a88d7b1bef9cec205f6.tar.bz2
aports-3f354e53c053b41e775a8a88d7b1bef9cec205f6.tar.xz
testing/php7-memcached: move to unmaintained
this abuild uses a snapshot of the php7 branch. this will result in different checksums of source after each commit in this branch. Please fix by providing a static source.
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/php7-memcached/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/unmaintained/php7-memcached/APKBUILD b/unmaintained/php7-memcached/APKBUILD
new file mode 100644
index 0000000000..1ca6ddd538
--- /dev/null
+++ b/unmaintained/php7-memcached/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabio Ribeiro <fabiorphp@gmail.com>
+# Maintainer: Fabio Ribeiro <fabiorphp@gmail.com>
+pkgname=php7-memcached
+_pkgreal=memcached
+_pkgrepo=php-memcached
+_pkgbranch=php7
+pkgver=3.0.0b1
+pkgrel=1
+pkgdesc="PHP extension for interfacing with memcached via libmemcached library"
+url="https://github.com/$_pkgrepo-dev/$_pkgrepo/tree/$_pkgbranch"
+arch="all"
+license="PHP"
+depends="php7-session"
+pecldepends="php7-dev autoconf zlib-dev"
+makedepends="$pecldepends libmemcached-dev"
+install=""
+subpackages=""
+source="$pkgname-$pkgver.tar.gz::https://github.com/$_pkgrepo-dev/$_pkgrepo/archive/$_pkgbranch.tar.gz"
+
+builddir="$srcdir"/$_pkgrepo-$_pkgbranch
+
+build() {
+ cd "$builddir"
+ phpize7 || return 1
+ ./configure \
+ --prefix=/usr \
+ --disable-memcached-sasl \
+ --with-php-config=php-config7 || return 1
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make INSTALL_ROOT="$pkgdir/" install || return 1
+ install -d "$pkgdir"/etc/php7/conf.d || return 1
+ echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/20_$_pkgreal.ini
+}
+
+md5sums="180153447695701d312316a466658918 php7-memcached-3.0.0b1.tar.gz"
+sha256sums="22b00c65301bb4bfc7b44280f2c6a34f4f01e40bf8b74bf8397705dfac00acd9 php7-memcached-3.0.0b1.tar.gz"
+sha512sums="b670ee0c6232ed0533c07a0a48ac60f51377d15897481b24117e3aea68171460cbd791a2ed3e2b1b11e654ea5bfb0f5eb98c92ef042c72f44e6628056ad90b19 php7-memcached-3.0.0b1.tar.gz"