aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2019-09-10 19:14:36 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2019-09-10 19:15:08 +0200
commit1e2adccab9e31f67fd7c96544985ee6305d139b9 (patch)
treefdeae1c8275515b8ba4a27ff7abc5291382be273 /unmaintained
parent3a5cce22c22bde92bc5c857b10471a27497b6f42 (diff)
downloadaports-1e2adccab9e31f67fd7c96544985ee6305d139b9.tar.bz2
aports-1e2adccab9e31f67fd7c96544985ee6305d139b9.tar.xz
unmaintained/diction: move from testing
Don't use it myself anymore and it doesn't seem to be very popular.
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/diction/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/unmaintained/diction/APKBUILD b/unmaintained/diction/APKBUILD
new file mode 100644
index 0000000000..3e4f8d0c89
--- /dev/null
+++ b/unmaintained/diction/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer:
+pkgname=diction
+pkgver=1.11
+pkgrel=1
+pkgdesc="Style checkers for improving your writing"
+url="https://www.gnu.org/software/diction/diction.html"
+arch="all"
+license="GPL-3.0-or-later"
+depends=""
+makedepends=""
+install=""
+subpackages="$pkgname-doc"
+source="https://ftp.gnu.org/gnu/$pkgname/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+ cd "$builddir"
+ update_config_sub
+}
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="f8be4c388c2659e91ba2dcfd5e3680aee0771b9b9a8c91a8877f6f61d5c014572c96ebf8e9cacbfa2afe2502e10957de9dd065245278cabeab13e28281404fb9 diction-1.11.tar.gz"