aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-10 09:52:08 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-11 09:26:21 -0300
commit3452b3b36177417eb33e428be58922fce59e408b (patch)
tree3ce89ef8b14ef04fede2db17e990cf03308b5e5e /unmaintained
parent64b113e1d0361b6c48ebe4f4df680dad808a8110 (diff)
downloadaports-3452b3b36177417eb33e428be58922fce59e408b.tar.bz2
aports-3452b3b36177417eb33e428be58922fce59e408b.tar.xz
unmaintained/terminator: move from community
- Requires python2 - Python3 porting in progress but not ready https://bugs.launchpad.net/terminator/+bug/1662544
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/terminator/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/unmaintained/terminator/APKBUILD b/unmaintained/terminator/APKBUILD
new file mode 100644
index 0000000000..65e26e5435
--- /dev/null
+++ b/unmaintained/terminator/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=terminator
+pkgver=1.91
+pkgrel=4
+pkgdesc="Terminal emulator that supports tabs and grids"
+url="https://gnometerminator.blogspot.fr/p/introduction.html"
+arch="noarch"
+license="GPL-2.0"
+depends="python2 py-gtk xdg-utils vte3 dbus-glib gettext intltool keybinder3
+ gsettings-desktop-schemas py2-gobject3 py2-cairo py-dbus py-psutil"
+makedepends="python2-dev"
+subpackages="$pkgname-doc $pkgname-lang"
+source="https://launchpad.net/$pkgname/gtk3/$pkgver/+download/$pkgname-$pkgver.tar.gz"
+
+
+check() {
+ python2 setup.py check
+}
+
+build() {
+ python2 setup.py build
+}
+
+package() {
+ python2 setup.py install --skip-build --root="${pkgdir}"
+ rm -f "${pkgdir}/usr/share/icons/hicolor/icon-theme.cache"
+}
+
+sha512sums="6feee96cda08f913601d3b01e51632bed87712ddb5ce577df1daa8a5fe4e8dc39075d5e21f87b865d1f007c7e1070ee2c0c814540c9c7786f0f24fbee762a03d terminator-1.91.tar.gz"