aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-08 19:52:44 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-08 19:52:45 -0300
commit9dbae86b733c5d459ba2e029aa54ec802178a8fe (patch)
tree6edf70e3090fa3e68cb2d11ebc0ab881e0e62b55 /unmaintained
parent99696b433e024b00696d9399fc4e642629320d16 (diff)
downloadaports-9dbae86b733c5d459ba2e029aa54ec802178a8fe.tar.bz2
aports-9dbae86b733c5d459ba2e029aa54ec802178a8fe.tar.xz
unmaintained/py-embedly: move from testing
- Last commit 5 years ago - But there is rudimentary python3 support via 2to3
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/py-embedly/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/unmaintained/py-embedly/APKBUILD b/unmaintained/py-embedly/APKBUILD
new file mode 100644
index 0000000000..9d89f4ee87
--- /dev/null
+++ b/unmaintained/py-embedly/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-embedly
+_pkgname=Embedly
+pkgver=0.5.0
+pkgrel=0
+pkgdesc="A Python module for Embedly"
+url="https://github.com/embedly/embedly-python"
+arch="noarch"
+license="BSD"
+depends="python2 py-httplib2"
+depends_dev=""
+makedepends="python2-dev py-setuptools"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python2 setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="67bfdf6496e219307ffbefef15748702 Embedly-0.5.0.tar.gz"
+sha256sums="e10bca4b5e25e8f30e93eb459921f787b08efc4004b6370a68f4c8984f6f16e1 Embedly-0.5.0.tar.gz"
+sha512sums="c85abacaa33b7897ccda79dc3746497f4eefe54bac3eef0aaa7c9120fec14ff6b7652a342303bea0667f60c2e31cb1591a22cddeff6827c87c6e2b1cc3274469 Embedly-0.5.0.tar.gz"