aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorMarian Buschsieweke <marian.buschsieweke@ovgu.de>2020-01-09 08:54:07 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-01-09 17:45:18 +0100
commitcd5ee22442af9a128e251983602fecc4bccffcbe (patch)
tree2a947637b7efbc0d9b60a323b109c53284cf2220 /unmaintained
parent3bfd1b2989bdf16f883a23c05c67b96a5ba8c36c (diff)
downloadaports-cd5ee22442af9a128e251983602fecc4bccffcbe.tar.bz2
aports-cd5ee22442af9a128e251983602fecc4bccffcbe.tar.xz
unmaintained/py3-nbxmpp: move from testing
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/py3-nbxmpp/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/unmaintained/py3-nbxmpp/APKBUILD b/unmaintained/py3-nbxmpp/APKBUILD
new file mode 100644
index 0000000000..09e52bce2e
--- /dev/null
+++ b/unmaintained/py3-nbxmpp/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer:
+pkgname=py3-nbxmpp
+_pkgname=nbxmpp
+pkgver=0.6.10
+pkgrel=2
+pkgdesc="A non-blocking XMPP implementation for python"
+url="https://dev.gajim.org/gajim/python-nbxmpp/"
+arch="noarch"
+license="GPL-3.0-or-later"
+depends="python3"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+options="!check" # no test suite
+builddir="$srcdir"/$_pkgname-$pkgver
+
+replaces=py-nbxmpp # Backwards compatibility
+provides=py-nbxmpp=$pkgver-r$pkgrel # Backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="df586498ea66da4b6720753b25bd0222ee3360684e844d0d5bc2f364c2566243cc358976fe34b050e3358c3e584f880d8ac1c34e84eca34efaa18ab0c2f37eaf nbxmpp-0.6.10.tar.gz"