aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-09 16:03:01 -0300
committerFrancesco Colista <fcolista@alpinelinux.org>2019-05-28 13:26:24 +0000
commitdbcb69980d97bf9ea0672f386c668d87ed751c45 (patch)
treee2d312810149fb21243ad3336fe34285ef6de6b1 /unmaintained
parent986e263188318a40f33ac9c6a8c44b96bf3c606b (diff)
downloadaports-dbcb69980d97bf9ea0672f386c668d87ed751c45.tar.bz2
aports-dbcb69980d97bf9ea0672f386c668d87ed751c45.tar.xz
unmaintained/global: move from testing
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/global/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/unmaintained/global/APKBUILD b/unmaintained/global/APKBUILD
new file mode 100644
index 0000000000..3a397cf6e7
--- /dev/null
+++ b/unmaintained/global/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Daniel Sabogal <dsabogalcc@gmail.com>
+# Maintainer:
+pkgname=global
+pkgver=6.6.3
+pkgrel=0
+pkgdesc="A source code tag system"
+options="!check" # No testsuite
+url="https://www.gnu.org/software/global"
+arch="all"
+license="GPL-3.0-or-later AND LGPL-3.0-or-later"
+makedepends="libltdl perl"
+subpackages="$pkgname-doc"
+source="https://ftp.gnu.org/gnu/global/$pkgname-$pkgver.tar.gz"
+
+build() {
+ ./configure \
+ --prefix=/usr \
+ --localstatedir=/var \
+ --with-exuberant-ctags=/usr/bin/ctags \
+ --disable-gtagscscope \
+ --disable-static
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir/" install
+
+ install -d "$pkgdir"/usr/share/emacs/site-lisp
+ install -d "$pkgdir"/usr/share/vim/vimfiles/plugin
+ mv "$pkgdir"/usr/share/gtags/gtags.el "$pkgdir"/usr/share/emacs/site-lisp/gtags.el
+ mv "$pkgdir"/usr/share/gtags/gtags.vim "$pkgdir"/usr/share/vim/vimfiles/plugin/gtags.vim
+ mv "$pkgdir"/usr/share/gtags/gtags-cscope.vim "$pkgdir"/usr/share/vim/vimfiles/plugin/gtags-cscope.vim
+}
+
+sha512sums="1edeb571e9105fb9c2a217bbfbcc3f273be1d7f078921c2ce1a9acb60ed1330268df6a68248a9676476338e74c4a77fb37bff68a6bf37f958ba99502b5c5755d global-6.6.3.tar.gz"