aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-09 02:20:18 -0300
committerAndy Postnikov <apostnikov@gmail.com>2019-05-13 00:34:18 +0300
commit6d2ac68d3350baee6458579e5e46e2ce5fde5679 (patch)
treecb4ad8586d9bdf984775bc29f0c788b9df9ae50b /unmaintained
parentd53aee486e69df22237862e1c7f7d13419181dc5 (diff)
downloadaports-6d2ac68d3350baee6458579e5e46e2ce5fde5679.tar.bz2
aports-6d2ac68d3350baee6458579e5e46e2ce5fde5679.tar.xz
unmaintained/enet: move from testing
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/enet/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/unmaintained/enet/APKBUILD b/unmaintained/enet/APKBUILD
new file mode 100644
index 0000000000..8cdc7e5bd6
--- /dev/null
+++ b/unmaintained/enet/APKBUILD
@@ -0,0 +1,23 @@
+# Contributor: Daniel Sabogal <dsabogalcc@gmail.com>
+# Maintainer:
+pkgname=enet
+pkgver=1.3.14
+pkgrel=0
+pkgdesc="Reliable UDP networking library"
+options="!check" # No testsuite
+url="http://enet.bespin.org"
+arch="all"
+license="MIT"
+subpackages="$pkgname-dev"
+source="http://enet.bespin.org/download/$pkgname-$pkgver.tar.gz"
+
+build() {
+ ./configure --prefix=/usr --disable-static
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir/" install
+}
+
+sha512sums="56011529c02ef085e57c77b7d6b72e5d0e76159ebf94a9980f50c2c8f7ef85a32a163e65d9414dda810fc2204e71c389745e7725a731371e2847a45bd4e18704 enet-1.3.14.tar.gz"