aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-31 04:23:57 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-31 04:23:58 -0300
commit270b203fe53421de936b07375039db774fe8e737 (patch)
treee484f37dbf749b8a4cbb20e1486ea89826351910 /unmaintained
parent19a7a447874e970e1b89a90b529df34c7e9c717b (diff)
downloadaports-270b203fe53421de936b07375039db774fe8e737.tar.bz2
aports-270b203fe53421de936b07375039db774fe8e737.tar.xz
unmaintained/py-httreplay: move from testing
- END-OF-LIFED on 2015 - Repo doesn't exist anymore - vcr.py is recommended
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/py-httreplay/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/unmaintained/py-httreplay/APKBUILD b/unmaintained/py-httreplay/APKBUILD
new file mode 100644
index 0000000000..a96711e610
--- /dev/null
+++ b/unmaintained/py-httreplay/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-httreplay
+_pkgname=httreplay
+pkgver=0.1.6
+pkgrel=0
+pkgdesc="A HTTP replay library for testing"
+url="http://github.com/davepeck/httreplay"
+arch="noarch"
+license="MIT"
+depends="python2"
+depends_dev=""
+makedepends="python2-dev py-setuptools"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python2 setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="1412c16295aff3862556900b77367972 httreplay-0.1.6.tar.gz"
+sha256sums="3ffd5f00cfffd4f10c0d67ffca481910b23775e70f11a2ed95e554e8f5c5b0e1 httreplay-0.1.6.tar.gz"
+sha512sums="13022180e9cbed6424a8153570177bc8a057cfe16a714050868bb343d71e1670dfccd17d29494156bda35b21156e2231b5c0d439f2953b9c5dbc0664e104b71d httreplay-0.1.6.tar.gz"