aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-08 14:09:19 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-08 14:23:44 -0300
commit48d0931b906a61156d378391e59aa6b7ccc822cc (patch)
tree034869699c68457b141039436b6a7983451c77d1 /unmaintained
parent997ea8ca959b2952fc1661e802929d10065e5fd7 (diff)
downloadaports-48d0931b906a61156d378391e59aa6b7ccc822cc.tar.bz2
aports-48d0931b906a61156d378391e59aa6b7ccc822cc.tar.xz
unmaintained/py3-flask-autoindex: move from testing
- Requires unpackaged 'flask-silk' that requires unpackaged 'flask-mail'
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/py3-flask-autoindex/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/unmaintained/py3-flask-autoindex/APKBUILD b/unmaintained/py3-flask-autoindex/APKBUILD
new file mode 100644
index 0000000000..0e91a32d11
--- /dev/null
+++ b/unmaintained/py3-flask-autoindex/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-flask-autoindex
+_pkgname=flask-autoindex
+pkgver=0.6.4
+pkgrel=0
+pkgdesc="Flask autoindex"
+url="https://pypi.python.org/pypi/Flask-AutoIndex"
+arch="noarch"
+license="MIT"
+# Missing 'flask-silk'
+depends="python3 py3-flask py3-future"
+makedepends="py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/general03/flask-autoindex/archive/v$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+replaces="py-flask-autoindex" # Backwards compatibility
+provides="py-flask-autoindex=$pkgver-r$pkgrel" # Backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="57888c2349c5dfbb2d567f92a377eaee7f011418cb8fcbf0bda8f063f1083ea5b436b52cb65ccf1b6f40c2db104b876e2da33a9d5a07b46d725a4579c4eaf2bd py3-flask-autoindex-0.6.4.tar.gz"