aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-11 23:55:20 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-11 23:56:17 -0300
commit4948c3c3f2c0e4daeba495e01b7ca69b779f1227 (patch)
tree4fe7efb7427d2e0073893909d44d379876176bbf /unmaintained
parente9798406b16a3ce5d0291c56777193fd54db9967 (diff)
downloadaports-4948c3c3f2c0e4daeba495e01b7ca69b779f1227.tar.bz2
aports-4948c3c3f2c0e4daeba495e01b7ca69b779f1227.tar.xz
community/llvm5: move from unmaintained
Turns out ghc still needs it
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/llvm5/0001-Disable-dynamic-lib-tests-for-musl-s-dlclose-is-noop.patch22
-rw-r--r--unmaintained/llvm5/APKBUILD265
-rw-r--r--unmaintained/llvm5/cmake-fix-libLLVM-name.patch26
-rw-r--r--unmaintained/llvm5/disable-FileSystemTest.CreateDir-perms-assert.patch61
-rw-r--r--unmaintained/llvm5/dynamiclibrary-fix-build-musl.patch40
-rw-r--r--unmaintained/llvm5/fix-CheckAtomic.cmake.patch22
-rw-r--r--unmaintained/llvm5/fix-LLVMConfig-cmake-install-prefix.patch24
-rw-r--r--unmaintained/llvm5/fix-memory-mf_exec-on-aarch64.patch33
-rw-r--r--unmaintained/llvm5/fix-return-type-in-ORC-readMem-client-interface.patch30
-rw-r--r--unmaintained/llvm5/fix-too-strict-gtest-banner-check.patch11
10 files changed, 0 insertions, 534 deletions
diff --git a/unmaintained/llvm5/0001-Disable-dynamic-lib-tests-for-musl-s-dlclose-is-noop.patch b/unmaintained/llvm5/0001-Disable-dynamic-lib-tests-for-musl-s-dlclose-is-noop.patch
deleted file mode 100644
index 1bf2fbb607..0000000000
--- a/unmaintained/llvm5/0001-Disable-dynamic-lib-tests-for-musl-s-dlclose-is-noop.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From f8e83c4c7866ae830abe9bec15cfe805dd825b6e Mon Sep 17 00:00:00 2001
-From: xentec <xentec@aix0.eu>
-Date: Tue, 12 Sep 2017 07:18:38 +0200
-Subject: [PATCH] Disable dynamic lib tests for musl's dlclose() is noop
-
----
- unittests/Support/CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/unittests/Support/CMakeLists.txt b/unittests/Support/CMakeLists.txt
-index 641163e..4f508d9 100644
---- a/unittests/Support/CMakeLists.txt
-+++ b/unittests/Support/CMakeLists.txt
-@@ -75,4 +75,4 @@ set_source_files_properties(AlignOfTest.cpp PROPERTIES COMPILE_FLAGS -w)
- # ManagedStatic.cpp uses <pthread>.
- target_link_libraries(SupportTests LLVMTestingSupport ${LLVM_PTHREAD_LIB})
-
--add_subdirectory(DynamicLibrary)
-+# add_subdirectory(DynamicLibrary)
---
-2.14.1
-
diff --git a/unmaintained/llvm5/APKBUILD b/unmaintained/llvm5/APKBUILD
deleted file mode 100644
index c976b40c98..0000000000
--- a/unmaintained/llvm5/APKBUILD
+++ /dev/null
@@ -1,265 +0,0 @@
-# Contributor: Travis Tilley <ttilley@gmail.com>
-# Contributor: Mitch Tishmack <mitch.tishmack@gmail.com>
-# Contributor: Jakub Jirutka <jakub@jirutka.cz>
-# Maintainer:
-_pkgname=llvm
-pkgver=5.0.2
-_majorver=${pkgver%%.*}
-pkgname=$_pkgname$_majorver
-pkgrel=1
-pkgdesc="Low Level Virtual Machine compiler system, version $_majorver"
-arch="all"
-url="https://llvm.org/"
-license="UOI-NCSA"
-depends_dev="$pkgname=$pkgver-r$pkgrel"
-makedepends="binutils-dev chrpath cmake file libffi-dev paxmark python2 py-setuptools zlib-dev"
-subpackages="$pkgname-static $pkgname-libs $pkgname-dev $pkgname-test-utils:_test_utils"
-source="https://releases.llvm.org/$pkgver/llvm-$pkgver.src.tar.xz
- cmake-fix-libLLVM-name.patch
- disable-FileSystemTest.CreateDir-perms-assert.patch
- 0001-Disable-dynamic-lib-tests-for-musl-s-dlclose-is-noop.patch
- fix-CheckAtomic.cmake.patch
- dynamiclibrary-fix-build-musl.patch
- fix-memory-mf_exec-on-aarch64.patch
- fix-LLVMConfig-cmake-install-prefix.patch
- fix-return-type-in-ORC-readMem-client-interface.patch
- fix-too-strict-gtest-banner-check.patch
- "
-builddir="$srcdir/$_pkgname-$pkgver.src"
-options="!checkroot"
-
-# ARM has few failures in test suite that we don't care about currently and
-# also it takes forever to run them on the builder.
-case "$CARCH" in
- arm*) options="$options !check";;
-esac
-
-# Whether is this package the default (latest) LLVM version.
-_default_llvm="no"
-
-if [ "$_default_llvm" = yes ]; then
- provides="llvm=$pkgver-r$pkgrel"
- replaces="llvm"
-fi
-
-# NOTE: It seems that there's no (sane) way how to change includedir, sharedir
-# etc. separately, just the CMAKE_INSTALL_PREFIX. Standard CMake variables and
-# even LLVM-specific variables, that are related to these paths, actually
-# don't work (in llvm 3.7).
-#
-# When building a software that depends on LLVM, utility llvm-config should be
-# used to discover where is LLVM installed. It provides options to print
-# path of bindir, includedir, and libdir separately, but in its source, all
-# these paths are actually hard-coded against INSTALL_PREFIX. We can patch it
-# and move paths manually, but I'm really not sure what it may break...
-#
-# Also note that we should *not* add version suffix to files in llvm bindir!
-# It breaks build system of some software that depends on LLVM, because they
-# don't expect these files to have a sufix.
-#
-# So, we install all the LLVM files into /usr/lib/llvm$_majorver.
-# BTW, Fedora and Debian do the same thing.
-#
-_prefix="usr/lib/llvm$_majorver"
-
-prepare() {
- default_prepare
- cd "$builddir"
-
- # https://bugs.llvm.org//show_bug.cgi?id=31870
- rm test/tools/llvm-symbolizer/print_context.c
-
- mkdir -p "$builddir"/build
-}
-
-build() {
- cd "$builddir"/build
-
- # Auto-detect it by guessing either.
- local ffi_include_dir="$(pkg-config --cflags-only-I libffi | sed 's|^-I||g')"
-
- cmake -Wno-dev \
- -DCMAKE_BUILD_TYPE=MinSizeRel \
- -DCMAKE_C_FLAGS_MINSIZEREL_INIT="$CFLAGS" \
- -DCMAKE_CXX_FLAGS_MINSIZEREL_INIT="$CXXFLAGS" \
- -DCMAKE_EXE_LINKER_FLAGS_MINSIZEREL_INIT="$LDFLAGS" \
- -DCMAKE_INSTALL_PREFIX=/$_prefix \
- \
- -DFFI_INCLUDE_DIR="$ffi_include_dir" \
- -DLLVM_BINUTILS_INCDIR=/usr/include \
- -DLLVM_BUILD_DOCS=OFF \
- -DLLVM_BUILD_EXAMPLES=OFF \
- -DLLVM_BUILD_EXTERNAL_COMPILER_RT=ON \
- -DLLVM_BUILD_LLVM_DYLIB=ON \
- -DLLVM_BUILD_TESTS=ON \
- -DLLVM_DEFAULT_TARGET_TRIPLE="$CBUILD" \
- -DLLVM_ENABLE_ASSERTIONS=OFF \
- -DLLVM_ENABLE_CXX1Y=ON \
- -DLLVM_ENABLE_FFI=ON \
- -DLLVM_ENABLE_LIBCXX=OFF \
- -DLLVM_ENABLE_PIC=ON \
- -DLLVM_ENABLE_RTTI=ON \
- -DLLVM_ENABLE_SPHINX=OFF \
- -DLLVM_ENABLE_TERMINFO=ON \
- -DLLVM_ENABLE_ZLIB=ON \
- -DLLVM_HOST_TRIPLE="$CHOST" \
- -DLLVM_INCLUDE_EXAMPLES=OFF \
- -DLLVM_LINK_LLVM_DYLIB=ON \
- -DLLVM_TARGETS_TO_BUILD='X86;ARM;AArch64;PowerPC;SystemZ;AMDGPU;NVPTX;Mips;BPF' \
- -DLLVM_APPEND_VC_REV=OFF \
- "$builddir"
-
- make llvm-tblgen
- make
-
- paxmark m \
- bin/llvm-rtdyld \
- bin/lli \
- bin/lli-child-target \
- unittests/ExecutionEngine/MCJIT/MCJITTests \
- unittests/ExecutionEngine/Orc/OrcJITTests \
- unittests/Support/SupportTests
-
- python2 ../utils/lit/setup.py build
-}
-
-check() {
- cd "$builddir"/build
-
- make check-llvm
-}
-
-package() {
- cd "$builddir"/build
-
- make DESTDIR="$pkgdir" install
-
- cd "$pkgdir"/$_prefix
-
- # Remove RPATHs.
- file lib/*.so bin/* \
- | awk -F: '$2~/ELF/{print $1}' \
- | xargs -r chrpath -d
-
- # Symlink files from /usr/lib/llvm*/bin to /usr/bin.
- mkdir -p "$pkgdir"/usr/bin
- local name newname path
- for path in bin/*; do
- name=${path##*/}
- # Add version infix/suffix to the executable name.
- case "$name" in
- llvm-*) newname="llvm$_majorver-${name#llvm-}";;
- *) newname="$name$_majorver";;
- esac
- # If this package provides=llvm (i.e. it's the default/latest
- # llvm package), omit version infix/suffix.
- if [ "$_default_llvm" = yes ]; then
- newname=$name
- fi
- case "$name" in
- FileCheck | obj2yaml | yaml2obj) continue;;
- esac
- ln -s ../lib/llvm$_majorver/bin/$name "$pkgdir"/usr/bin/$newname
- done
-
- # Move /usr/lib/$pkgname/include/ into /usr/include/$pkgname/
- # and symlink it back.
- _mv include/* "$pkgdir"/usr/include/$pkgname/
- rmdir include
- ln -s ../../include/$pkgname include
-
- # Move /usr/lib/$pkgname/lib/cmake/llvm/ into /usr/lib/cmake/$pkgname/
- # and symlink it back.
- _mv lib/cmake/llvm/* "$pkgdir"/usr/lib/cmake/$pkgname/
- rmdir lib/cmake/llvm
- ln -s ../../../cmake/$pkgname lib/cmake/llvm
-}
-
-static() {
- pkgdesc="LLVM $_majorver static libraries"
- _common_subpkg
-
- _mv "$pkgdir"/$_prefix/lib/*.a "$subpkgdir"/$_prefix/lib/
-}
-
-libs() {
- pkgdesc="LLVM $_majorver runtime library"
- local soname="libLLVM-$_majorver.0.so"
- local soname2="libLLVM-$pkgver.so"
- _common_subpkg
-
- mkdir -p "$subpkgdir"
- cd "$subpkgdir"
-
- # libLLVM should be in /usr/lib. This is needed for binaries that are
- # dynamically linked with libLLVM, so they can find it on default path.
- _mv "$pkgdir"/$_prefix/lib/$soname usr/lib/
- ln -s $soname usr/lib/$soname2
-
- # And also symlink it back to the LLVM prefix.
- mkdir -p $_prefix/lib
- ln -s ../../$soname $_prefix/lib/$soname
- ln -s ../../$soname $_prefix/lib/$soname2
-}
-
-dev() {
- _common_subpkg
- default_dev
- cd "$subpkgdir"
-
- _mv "$pkgdir"/$_prefix/lib $_prefix/
- _mv "$pkgdir"/$_prefix/include $_prefix/
-
- _mv "$pkgdir"/$_prefix/bin/llvm-config $_prefix/bin/
-
- if [ "$_default_llvm" = yes ]; then
- ln -sf llvm$_majorver/lib/LLVMgold.so usr/lib/
- ln -sf llvm$_majorver/lib/libLTO.so usr/lib/
- ln -sf llvm$_majorver usr/lib/cmake/llvm
- fi
-}
-
-_test_utils() {
- pkgdesc="LLVM $_majorver utilities for executing LLVM and Clang style test suites"
- depends="python2 py-setuptools"
- _common_subpkg
- replaces=""
-
- local litver=$(python2 "$builddir"/utils/lit/setup.py --version 2>/dev/null \
- | sed 's/\.dev.*$//')
- test -n "$litver"
- provides="$provides lit=$litver-r$pkgrel"
-
- cd "$builddir"/build
-
- install -D -m 755 bin/count "$subpkgdir"/$_prefix/bin/count
- install -D -m 755 bin/FileCheck "$subpkgdir"/$_prefix/bin/FileCheck
- install -D -m 755 bin/not "$subpkgdir"/$_prefix/bin/not
-
- python2 ../utils/lit/setup.py install --prefix=/usr --root="$subpkgdir"
- ln -s ../../../bin/lit "$subpkgdir"/$_prefix/bin/lit
-}
-
-_common_subpkg() {
- if [ "$_default_llvm" = yes ]; then
- replaces="llvm${subpkgname#$pkgname}"
- provides="$replaces=$pkgver-r$pkgrel"
- fi
-}
-
-_mv() {
- local dest; for dest; do true; done # get last argument
- mkdir -p "$dest"
- mv $@
-}
-
-sha512sums="3588be5ed969c3f7f6f16f56a12a6af2814d3d3c960d4a36ffebb0446cc75f19220bccee7fc605f9b01f5d5c188a905a046193cc12dec42dd5922048b5c27fe1 llvm-5.0.2.src.tar.xz
-6d1a716e5aa24e6b9a3acf4cc11e2504b1b01abf574074e9e5617b991de87d5e4e687eb18e85e73d5e632568afe2fc357771c4c96f9e136502071991496fb78c cmake-fix-libLLVM-name.patch
-49c47f125014b60d0ea7870f981a2c1708ad705793f89287ed846ee881a837a4dc0170bf467e03f2ef56177473128945287749ac80dc2d13cfabcf8b929ba58a disable-FileSystemTest.CreateDir-perms-assert.patch
-695502bd3b5454c2f5630c59a8cf5f8aeb0deac16a76a8a4df34849e1e35c12ed4234572a320fe4c7e96f974f572f429eb816c5aa3dcfb17057f550eac596495 0001-Disable-dynamic-lib-tests-for-musl-s-dlclose-is-noop.patch
-3bcfeccc1f14567f99029a131b1289290226d48855857f2eb6a251e041981a8b8b2d7965099df16ebf0a406e48130679f97235ef3f3524577413bb51cf40e613 fix-CheckAtomic.cmake.patch
-5e61bbeafa64dd858cde2e85d3001f3abc0379f7ca057e9f49684eeabc8b4663f79136d688aff8a83a480b3e7cde76823d381e9dd6933187a36ff59da85532b2 dynamiclibrary-fix-build-musl.patch
-c9ef3cd95c4bd1d6ac69bbcd471b01755126d00f59d27d4a2a2ef5623943be73f8407e2fd731294d1a9d81a66e459f45f3f1d5dc5f9646f4f2fb2d8d891b5279 fix-memory-mf_exec-on-aarch64.patch
-7d4825d16107e56a14b7b05be847f03d75e2e05952bea0742a1233b5b0441c9934d8058e612abb6471272884372d9bfd3348355fbd3c19cba82a554003cc3eec fix-LLVMConfig-cmake-install-prefix.patch
-f57c734687c8ceae8d1bbfcbfdeecb75a5059a112967f4ba639d78d2484e0cc1deabf02ba2d3a6f5283443bf8b3230f38ad143800f8f3327cca0d2691a3ddc3d fix-return-type-in-ORC-readMem-client-interface.patch
-95b335237328e249c7de71648385d90e736932b1d47cf07a9188ea98d4c2bc740f217e4145f65cb9822058515b6fccaeaf28fb0319fd692e7278a2d542186f54 fix-too-strict-gtest-banner-check.patch"
diff --git a/unmaintained/llvm5/cmake-fix-libLLVM-name.patch b/unmaintained/llvm5/cmake-fix-libLLVM-name.patch
deleted file mode 100644
index cb29fe2efc..0000000000
--- a/unmaintained/llvm5/cmake-fix-libLLVM-name.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Include version in name of shared libs
-
-libLLVM.so -> libLLVM-$MAJOR.$MINOR.so
-
-Source: http://pkgs.fedoraproject.org/cgit/rpms/llvm3.9.git/tree/llvm-soversion.patch?id=3dac83eaa5b88f550ae50125b14b8f644e10617b
---- a/cmake/modules/AddLLVM.cmake
-+++ b/cmake/modules/AddLLVM.cmake
-@@ -450,6 +450,18 @@
- PREFIX ""
- )
- endif()
-+
-+ # Set SOVERSION on shared libraries that lack explicit SONAME
-+ # specifier, on *nix systems that are not Darwin.
-+ if(UNIX AND NOT APPLE AND NOT ARG_SONAME)
-+ set_target_properties(${name}
-+ PROPERTIES
-+ # Concatenate the version numbers since ldconfig expects exactly
-+ # one component indicating the ABI version, while LLVM uses
-+ # major+minor for that.
-+ SOVERSION ${LLVM_VERSION_MAJOR}.${LLVM_VERSION_MINOR}
-+ VERSION ${LLVM_VERSION_MAJOR}.${LLVM_VERSION_MINOR}.${LLVM_VERSION_PATCH}${LLVM_VERSION_SUFFIX})
-+ endif()
- endif()
-
- if(ARG_MODULE OR ARG_SHARED)
diff --git a/unmaintained/llvm5/disable-FileSystemTest.CreateDir-perms-assert.patch b/unmaintained/llvm5/disable-FileSystemTest.CreateDir-perms-assert.patch
deleted file mode 100644
index e73ce9b6f0..0000000000
--- a/unmaintained/llvm5/disable-FileSystemTest.CreateDir-perms-assert.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-Do not assert permissions of file created in /tmp directory.
-
-This assertion fails, probably due to some specific setup of /tmp
-on build servers.
-
- FAIL: LLVM-Unit :: Support/SupportTests/FileSystemTest.CreateDir (1293 of 17222)
- ******************** TEST 'LLVM-Unit :: Support/SupportTests/FileSystemTest.CreateDir' FAILED ********************
- Note: Google Test filter = FileSystemTest.CreateDir
- [==========] Running 1 test from 1 test case.
- [----------] Global test environment set-up.
- [----------] 1 test from FileSystemTest
- [ RUN ] FileSystemTest.CreateDir
- /home/buildozer/aports/testing/llvm3.9/src/llvm-3.9.1.src/unittests/Support/Path.cpp:591: Failure
- Value of: fs::perms::owner_read | fs::perms::owner_exe
- Actual: 320
- Expected: Status.permissions() & fs::perms::all_all
- Which is: 448
-
---- a/unittests/Support/Path.cpp
-+++ b/unittests/Support/Path.cpp
-@@ -579,23 +579,23 @@
- ASSERT_NO_ERROR(fs::remove(Twine(TestDirectory) + "foo"));
-
- #ifdef LLVM_ON_UNIX
-- // Set a 0000 umask so that we can test our directory permissions.
-- mode_t OldUmask = ::umask(0000);
--
-- fs::file_status Status;
-- ASSERT_NO_ERROR(
-- fs::create_directory(Twine(TestDirectory) + "baz500", false,
-- fs::perms::owner_read | fs::perms::owner_exe));
-- ASSERT_NO_ERROR(fs::status(Twine(TestDirectory) + "baz500", Status));
-- ASSERT_EQ(Status.permissions() & fs::perms::all_all,
-- fs::perms::owner_read | fs::perms::owner_exe);
-- ASSERT_NO_ERROR(fs::create_directory(Twine(TestDirectory) + "baz777", false,
-- fs::perms::all_all));
-- ASSERT_NO_ERROR(fs::status(Twine(TestDirectory) + "baz777", Status));
-- ASSERT_EQ(Status.permissions() & fs::perms::all_all, fs::perms::all_all);
--
-- // Restore umask to be safe.
-- ::umask(OldUmask);
-+// // Set a 0000 umask so that we can test our directory permissions.
-+// mode_t OldUmask = ::umask(0000);
-+//
-+// fs::file_status Status;
-+// ASSERT_NO_ERROR(
-+// fs::create_directory(Twine(TestDirectory) + "baz500", false,
-+// fs::perms::owner_read | fs::perms::owner_exe));
-+// ASSERT_NO_ERROR(fs::status(Twine(TestDirectory) + "baz500", Status));
-+// ASSERT_EQ(Status.permissions() & fs::perms::all_all,
-+// fs::perms::owner_read | fs::perms::owner_exe);
-+// ASSERT_NO_ERROR(fs::create_directory(Twine(TestDirectory) + "baz777", false,
-+// fs::perms::all_all));
-+// ASSERT_NO_ERROR(fs::status(Twine(TestDirectory) + "baz777", Status));
-+// ASSERT_EQ(Status.permissions() & fs::perms::all_all, fs::perms::all_all);
-+//
-+// // Restore umask to be safe.
-+// ::umask(OldUmask);
- #endif
-
- #ifdef LLVM_ON_WIN32
diff --git a/unmaintained/llvm5/dynamiclibrary-fix-build-musl.patch b/unmaintained/llvm5/dynamiclibrary-fix-build-musl.patch
deleted file mode 100644
index a9bbe168e9..0000000000
--- a/unmaintained/llvm5/dynamiclibrary-fix-build-musl.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From ae8900a8833835309aecb0a3d947c2ae46fd86c3 Mon Sep 17 00:00:00 2001
-From: Keno Fischer <keno@alumni.harvard.edu>
-Date: Thu, 26 Oct 2017 16:44:13 +0000
-Subject: [PATCH] [DynamicLibrary] Fix build on musl libc
-
-Summary:
-On musl libc, stdin/out/err are defined as `FILE* const` globals,
-and their address is not implicitly convertible to void *,
-or at least gcc 6 doesn't allow it, giving errors like:
-
-```
-error: cannot initialize return object of type 'void *' with an rvalue of type 'FILE *const *' (aka '_IO_FILE *const *')
- EXPLICIT_SYMBOL(stderr);
- ^~~~~~~~~~~~~~~~~~~~~~~
-```
-
-Add an explicit cast to fix that problem.
-
-Reviewers: marsupial, krytarowski, dim
-Reviewed By: dim
-Differential Revision: https://reviews.llvm.org/D39297
-
-git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@316672 91177308-0d34-0410-b5e6-96231b3b80d8
----
- lib/Support/Unix/DynamicLibrary.inc | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/lib/Support/Unix/DynamicLibrary.inc b/lib/Support/Unix/DynamicLibrary.inc
-index f05103ccd1e..029451f347e 100644
---- a/lib/Support/Unix/DynamicLibrary.inc
-+++ b/lib/Support/Unix/DynamicLibrary.inc
-@@ -71,7 +71,7 @@ void *DynamicLibrary::HandleSet::DLSym(void *Handle, const char *Symbol) {
- // Must declare the symbols in the global namespace.
- static void *DoSearch(const char* SymbolName) {
- #define EXPLICIT_SYMBOL(SYM) \
-- extern void *SYM; if (!strcmp(SymbolName, #SYM)) return &SYM
-+ extern void *SYM; if (!strcmp(SymbolName, #SYM)) return (void*)&SYM
-
- // If this is darwin, it has some funky issues, try to solve them here. Some
- // important symbols are marked 'private external' which doesn't allow
diff --git a/unmaintained/llvm5/fix-CheckAtomic.cmake.patch b/unmaintained/llvm5/fix-CheckAtomic.cmake.patch
deleted file mode 100644
index a5309de6cf..0000000000
--- a/unmaintained/llvm5/fix-CheckAtomic.cmake.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-This cmake file uses command CHECK_LIBRARY_EXISTS that is defined in
-module CheckLibraryExists, but it does not include that module.
-
-This caused build error in lldb, but only on x86 (not x86_64)...
-
- -- Performing Test HAVE_CXX_ATOMICS64_WITHOUT_LIB - Failed
- CMake Error at /usr/lib/llvm4/lib/cmake/llvm/CheckAtomic.cmake:66 (check_library_exists):
- Unknown CMake command "check_library_exists".
- Call Stack (most recent call first):
- cmake/modules/LLDBStandalone.cmake:90 (include)
- CMakeLists.txt:3 (include)
-
---- a/cmake/modules/CheckAtomic.cmake
-+++ b/cmake/modules/CheckAtomic.cmake
-@@ -1,6 +1,7 @@
- # atomic builtins are required for threading support.
-
- INCLUDE(CheckCXXSourceCompiles)
-+INCLUDE(CheckLibraryExists)
-
- # Sometimes linking against libatomic is required for atomic ops, if
- # the platform doesn't support lock-free atomics.
diff --git a/unmaintained/llvm5/fix-LLVMConfig-cmake-install-prefix.patch b/unmaintained/llvm5/fix-LLVMConfig-cmake-install-prefix.patch
deleted file mode 100644
index b7e3dbe294..0000000000
--- a/unmaintained/llvm5/fix-LLVMConfig-cmake-install-prefix.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Fix LLVMConfig.cmake being generated to use correct LLVM_INSTALL_PREFIX
-(e.g. /usr/lib/llvm5).
-
-This is needed e.g. for building lldb.
-
---- a/cmake/modules/CMakeLists.txt
-+++ b/cmake/modules/CMakeLists.txt
-@@ -75,15 +75,7 @@
-
- # Generate LLVMConfig.cmake for the install tree.
- set(LLVM_CONFIG_CODE "
--# Compute the installation prefix from this LLVMConfig.cmake file location.
--get_filename_component(LLVM_INSTALL_PREFIX \"\${CMAKE_CURRENT_LIST_FILE}\" PATH)")
--# Construct the proper number of get_filename_component(... PATH)
--# calls to compute the installation prefix.
--string(REGEX REPLACE "/" ";" _count "${LLVM_INSTALL_PACKAGE_DIR}")
--foreach(p ${_count})
-- set(LLVM_CONFIG_CODE "${LLVM_CONFIG_CODE}
--get_filename_component(LLVM_INSTALL_PREFIX \"\${LLVM_INSTALL_PREFIX}\" PATH)")
--endforeach(p)
-+set(LLVM_INSTALL_PREFIX \"${CMAKE_INSTALL_PREFIX}\")")
- set(LLVM_CONFIG_INCLUDE_DIRS "\${LLVM_INSTALL_PREFIX}/include")
- set(LLVM_CONFIG_LIBRARY_DIRS "\${LLVM_INSTALL_PREFIX}/lib\${LLVM_LIBDIR_SUFFIX}")
- set(LLVM_CONFIG_CMAKE_DIR "\${LLVM_INSTALL_PREFIX}/${LLVM_INSTALL_PACKAGE_DIR}")
diff --git a/unmaintained/llvm5/fix-memory-mf_exec-on-aarch64.patch b/unmaintained/llvm5/fix-memory-mf_exec-on-aarch64.patch
deleted file mode 100644
index a70b397333..0000000000
--- a/unmaintained/llvm5/fix-memory-mf_exec-on-aarch64.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-Fix failures in AllocationTests/MappedMemoryTest.* on aarch64:
-
- Failing Tests (8):
- LLVM-Unit :: Support/./SupportTests/AllocationTests/MappedMemoryTest.AllocAndRelease/3
- LLVM-Unit :: Support/./SupportTests/AllocationTests/MappedMemoryTest.DuplicateNear/3
- LLVM-Unit :: Support/./SupportTests/AllocationTests/MappedMemoryTest.EnabledWrite/3
- LLVM-Unit :: Support/./SupportTests/AllocationTests/MappedMemoryTest.MultipleAllocAndRelease/3
- LLVM-Unit :: Support/./SupportTests/AllocationTests/MappedMemoryTest.SuccessiveNear/3
- LLVM-Unit :: Support/./SupportTests/AllocationTests/MappedMemoryTest.UnalignedNear/3
- LLVM-Unit :: Support/./SupportTests/AllocationTests/MappedMemoryTest.ZeroNear/3
- LLVM-Unit :: Support/./SupportTests/AllocationTests/MappedMemoryTest.ZeroSizeNear/3
-
-Upstream-Issue: https://bugs.llvm.org/show_bug.cgi?id=14278#c10
-
---- a/lib/Support/Unix/Memory.inc
-+++ b/lib/Support/Unix/Memory.inc
-@@ -54,7 +54,7 @@
- llvm::sys::Memory::MF_EXEC:
- return PROT_READ | PROT_WRITE | PROT_EXEC;
- case llvm::sys::Memory::MF_EXEC:
--#if defined(__FreeBSD__)
-+#if defined(__FreeBSD__) || (defined(__linux__) && (defined(__aarch64__) || defined(__powerpc64__)))
- // On PowerPC, having an executable page that has no read permission
- // can have unintended consequences. The function InvalidateInstruction-
- // Cache uses instructions dcbf and icbi, both of which are treated by
-@@ -62,6 +62,7 @@
- // executing these instructions will result in a segmentation fault.
- // Somehow, this problem is not present on Linux, but it does happen
- // on FreeBSD.
-+ // The same problem is present even on aarch64 Linux (at least on musl).
- return PROT_READ | PROT_EXEC;
- #else
- return PROT_EXEC;
diff --git a/unmaintained/llvm5/fix-return-type-in-ORC-readMem-client-interface.patch b/unmaintained/llvm5/fix-return-type-in-ORC-readMem-client-interface.patch
deleted file mode 100644
index 5296fdb0ba..0000000000
--- a/unmaintained/llvm5/fix-return-type-in-ORC-readMem-client-interface.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 5cea35478aaaac7728a50cbafd3770f96162f7ac Mon Sep 17 00:00:00 2001
-From: Tilmann Scheller <tschelle@redhat.com>
-Date: Thu, 1 Feb 2018 11:40:01 -0600
-Subject: [PATCH] Fix return type in ORC readMem() client interface.
-
-GCC 8.0.1 detects the type mismatch and causes the compilation to fail. Clang
-and earlier versions of GCC don't detect the issue.
-
-Fixes rhbz#1540620.
----
- include/llvm/ExecutionEngine/Orc/OrcRemoteTargetClient.h | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/include/llvm/ExecutionEngine/Orc/OrcRemoteTargetClient.h b/include/llvm/ExecutionEngine/Orc/OrcRemoteTargetClient.h
-index da02250ba16..bed472e2e0e 100644
---- a/include/llvm/ExecutionEngine/Orc/OrcRemoteTargetClient.h
-+++ b/include/llvm/ExecutionEngine/Orc/OrcRemoteTargetClient.h
-@@ -713,8 +713,8 @@ private:
-
- uint32_t getTrampolineSize() const { return RemoteTrampolineSize; }
-
-- Expected<std::vector<char>> readMem(char *Dst, JITTargetAddress Src,
-- uint64_t Size) {
-+ Expected<std::vector<uint8_t>> readMem(char *Dst, JITTargetAddress Src,
-+ uint64_t Size) {
- // Check for an 'out-of-band' error, e.g. from an MM destructor.
- if (ExistingError)
- return std::move(ExistingError);
---
-2.16.1
diff --git a/unmaintained/llvm5/fix-too-strict-gtest-banner-check.patch b/unmaintained/llvm5/fix-too-strict-gtest-banner-check.patch
deleted file mode 100644
index 412888e420..0000000000
--- a/unmaintained/llvm5/fix-too-strict-gtest-banner-check.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/utils/lit/lit/formats/googletest.py
-+++ b/utils/lit/lit/formats/googletest.py
-@@ -42,7 +42,7 @@
- for ln in output.splitlines(False): # Don't keep newlines.
- ln = lit.util.to_string(ln)
-
-- if 'Running main() from gtest_main.cc' in ln:
-+ if ln.startswith('Running main() from '):
- # Upstream googletest prints this to stdout prior to running
- # tests. LLVM removed that print statement in r61540, but we
- # handle it here in case upstream googletest is being used.