aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 11:20:18 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 11:20:21 -0300
commit86176ae86543c34bd97bc783819d2bd5a9f53b2b (patch)
tree39df30a5eaa8e6b57a0ac269a331da1c18edb2c2 /unmaintained
parentde5a24e202000a9f554caac6e493a0ee744d260d (diff)
downloadaports-86176ae86543c34bd97bc783819d2bd5a9f53b2b.tar.bz2
aports-86176ae86543c34bd97bc783819d2bd5a9f53b2b.tar.xz
unmaintained/py-centinel: move from testing
- Old version - New version has some unpackaged dependencies - Also their dependency tracking is wack - dnspython declared twice - both BeautifulSoup and bs4 (same thing) - Current version is Python2 only
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/py-centinel/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/unmaintained/py-centinel/APKBUILD b/unmaintained/py-centinel/APKBUILD
new file mode 100644
index 0000000000..ba2230423f
--- /dev/null
+++ b/unmaintained/py-centinel/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-centinel
+_pkgname=centinel
+pkgver=0.1.3
+pkgrel=0
+pkgdesc="A tool used to detect network interference and internet censorship"
+url="https://github.com/projectbismark/centinel"
+arch="noarch"
+license="MIT"
+depends="python2 py-dnspython"
+depends_dev=""
+makedepends="python2-dev py-setuptools"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python2 setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="51dc7adedc5063c341a42b16ffb73d50 centinel-0.1.3.tar.gz"
+sha256sums="6cebe17a0864e0576b3eb207f29b0c72962563b29b408a5c36a75d4e7f861096 centinel-0.1.3.tar.gz"
+sha512sums="d20a4077bb416af653d8fd02b18dcb2060637d431013c26a2b3941504b01f733e259c5bcc0dec016687fea0cbc617542a7363d42c40230c0a904d16dde31e1a5 centinel-0.1.3.tar.gz"