aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-22 17:29:31 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-22 23:18:32 -0300
commit883b7003dc3cfbcae44b2e25044b6803215e16bc (patch)
treec10e2d9713214165fb8f917b73d586624d91c198 /unmaintained
parent08d404650a1606b07279addfd6e8a48bf29b2b66 (diff)
downloadaports-883b7003dc3cfbcae44b2e25044b6803215e16bc.tar.bz2
aports-883b7003dc3cfbcae44b2e25044b6803215e16bc.tar.xz
unmaintained/dstat: move from testing
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/dstat/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/unmaintained/dstat/APKBUILD b/unmaintained/dstat/APKBUILD
new file mode 100644
index 0000000000..7ad3ef7cad
--- /dev/null
+++ b/unmaintained/dstat/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer:
+pkgname=dstat
+pkgver=0.7.3
+pkgrel=0
+pkgdesc="A versatile resource statistics tool"
+url="http://dag.wieers.com/home-made/dstat/"
+arch="noarch"
+license="GPL-2.0-or-later"
+depends="python2"
+depends_dev="python2-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="${pkgname}-${pkgver}.tar.gz::https://github.com/dagwieers/${pkgname}/archive/${pkgver}.tar.gz"
+
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ make || return 1
+ return 0
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR=$pkgdir install || return 1
+}
+
+md5sums="be27c905e6737993306dbbcee735e8ad dstat-0.7.3.tar.gz"
+sha256sums="46e63821857b69fbc60cb2c7d893ccdd6f31cd9ef24b8bb0b68951e1c7374898 dstat-0.7.3.tar.gz"
+sha512sums="db37cc8bb7afd235ae9088e76c4defaa4d76651b111fbfdcd0980bc96376de20d57964912799a413397a79651730503bdeb8fea5cb97ab4d6d81632f528aefd2 dstat-0.7.3.tar.gz"