aboutsummaryrefslogtreecommitdiffstats
path: root/unmaintained
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 14:12:59 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 14:47:57 -0300
commit8eb69640b921fee58821daf5f294c63630c2d915 (patch)
tree1edd8ad11612b0fed2dae8263a9d47f7afada9ec /unmaintained
parent63897d5380cf7b1543f23f53859d80e2d5851a07 (diff)
downloadaports-8eb69640b921fee58821daf5f294c63630c2d915.tar.bz2
aports-8eb69640b921fee58821daf5f294c63630c2d915.tar.xz
unmaintained/cherrytree: move from testing
- Python2 only
Diffstat (limited to 'unmaintained')
-rw-r--r--unmaintained/cherrytree/APKBUILD28
-rw-r--r--unmaintained/cherrytree/update-desktop-database-removal.patch10
2 files changed, 38 insertions, 0 deletions
diff --git a/unmaintained/cherrytree/APKBUILD b/unmaintained/cherrytree/APKBUILD
new file mode 100644
index 0000000000..52f9d7b84b
--- /dev/null
+++ b/unmaintained/cherrytree/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Paul Bredbury <brebs@sent.com>
+pkgname=cherrytree
+pkgver=0.38.8
+pkgrel=0
+pkgdesc="Hierarchical note-taking app featuring rich text"
+url="https://www.giuspen.com/cherrytree/"
+arch="noarch"
+license="GPL-3.0-or-later"
+depends="py-dbus py-gtk py-pygtksourceview2"
+makedepends="gettext"
+subpackages="$pkgname-doc $pkgname-lang"
+source="https://www.giuspen.com/software/$pkgname-$pkgver.tar.xz
+ update-desktop-database-removal.patch"
+options="!check" # No test suite
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="0ba188c93ce8c3eee73f7c8622872305df95c2c545d1bfd486af744229d6edc166ac6a9e10621d059a245d01b5458ad6dd8efdfdb9265cef0028f2426cfd1f72 cherrytree-0.38.8.tar.xz
+d56dbb037c9205d038892bd4d7fd48ff4406162a1114ab7b9991b76f974fb683e1d3ddc3bfaa37214269c032c2908ec00e5ad17e2c6439a280eff8881e291428 update-desktop-database-removal.patch"
diff --git a/unmaintained/cherrytree/update-desktop-database-removal.patch b/unmaintained/cherrytree/update-desktop-database-removal.patch
new file mode 100644
index 0000000000..80275f2302
--- /dev/null
+++ b/unmaintained/cherrytree/update-desktop-database-removal.patch
@@ -0,0 +1,10 @@
+Run by Alpine's desktop-file-utils.trigger instead
+
+diff -Naur a/setup.py b/setup.py
+--- a/setup.py 2019-01-02 08:01:06.000000000 +0000
++++ b/setup.py 2019-03-20 21:12:53.570596428 +0000
+@@ -205,4 +205,3 @@
+ },
+ distclass=CherryTreeDist
+ )
+- subprocess.call("update-desktop-database")